
About
Internet Server Monitor is a network server monitoring tool enabling System Administrators to monitor servers and
the network applications they host for failures, recoveries and load. Minimize downtime by configuring the
software to notify your on call system administrator when a server application fails or system performance
degrades.

Features at a Glance

�x         Monitors servers and the network applications they run
�x         Supports multiple types of alerts, notifications and actions, including SNMP traps 
�x         Stores monitor results to SQL Server, MySQL or to file
�x         Automatically publishes network status to your intranet website
�x         Supports hierarchical/dependency rules and schedules
�x         Automatically clears failures enabling nag alerts to fire
�x         Automatically stops monitors during maintenance windows
�x         Includes system tray status icon
�x         No installation requirements on managed computers

Interrogation

Internet Server Monitor not only checks the availability of server applications but in most cases includes
functionality to test the application performance. For example, an HTTP or Web monitor can be created to test
the availability of the server and verify the returned URL or document contains the desired content.

History

In order to comply with regulatory agency requirements, Internet Server Monitor saves all monitor results to either
SQL Server, MySQL or to file. When saving to a database, System Administrators can create their own reports
as well as data mine historical data.

Hierarchical Monitoring

System administrators can setup monitoring hierarchy to shutdown, start, or throttle up backup system
monitoring when a primary server fails. For example, when a ping monitor fails on a primary server the system
can shutdown the dependent memory and CPU monitors while also throttling up ping, memory and CPU monitors
on your backup server.

Windows Server Monitoring

Monitor Windows Services, CPU load, and memory utilization. Using WMI Internet Server Monitor polls the status
of Windows Services running on remote computers. Depending on the service state, the monitor can optionally
start or stop the service. CPU load and memory utilization are polled over time and alerts fired based on
averages.

SSL Certificate and Domain Name Expiration Date Monitoring

Don't get caught with expired SSL Certificates or domain names. Use Internet Server Monitor to receive
notification well in advance of your Secure Certificate and registered domain name expiration dates.

Monitoring Functions

HTTP (Web) Checks HTTP and HTTPS servers/sites by connecting and optionally
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checking the URL content. Supports authentication and regular
expressions.

SMTP (Outgoing Mail) Checks SMTP mail servers by connecting and optionally sending an email.
Supports SSL.

POP3 (Incoming Mail) Checks POP3 mail servers by connecting and optionally authenticating.
Supports SSL.

IMAP Checks IMAP mail servers by connecting and optionally authenticating.
Supports SSL.

FTP (File Transfer) Checks FTP servers/sites by connecting and optionally authenticating.

ICMP (Ping) Checks a remote host for availability by echoing data within a user defined
timeout period.

TCP Ports Checks if a port is responding and optionally checks its response against a
text pattern.

DNS Checks DNS servers by connecting and validating the IP address returned
for a given address.

Microsoft SQL Server
MySQL
ODBC Data Sources

Checks the availability of a database by connecting and optimally running a
SQL command.

Windows Services Checks the status of Windows Services and optionally starts or stops the
service depending on the state.

CPU Load Checks the CPU load over a period of time.

Memory Utilization Checks the memory utilization over a period of time.

NTP (Time Server) Checks time servers by connecting, retrieving the current time, and
optionally setting the time on the local server.

NNTP (News Server) Checks news servers by connecting and optionally opening a news group.

SSL Certificate Checks SSL Certification expiration dates.

Domain Expiration Checks registered domain name expiration dates against public WHOIS
servers.

Alerts, Notifications and A ctions

When Internet Server Monitor detects a failure, degraded performance or recovery, any one or combination of the
following alert notifications can be fired:

Email Sends an email message.

Pager (SMS) Sends a text messages using Clickatell’s web email-to-SMS online gateway
service or any third party email-to-SMS gateway.

Message Box Displays a custom message box that stores alert history so your desktop does
not fill with hundreds of messages.

Sound Plays a sound.

Tray Icon Updates the tray icon with the current global status.

Tray Icon Popup Displays a balloon window above the tray icon that contains the failure or
recovery.

Event Log Entry Writes the failure or recovery to any Windows Event Log.

Syslog Message Forwards the failure or recovery to your syslog server.
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Start Process Runs an interactive or background process on the local server.

SNMP Trap Sends a SNMP trap via Microsoft’s SNMP Service.
All string based alerts can be customized using replacement variables.

For more information, s ee:

How it Works

Monitoring Servers
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How it Works
 

Components

Internet Server Monitor consists of three (3) major components:

The User Interface  is used to configure monitors.

The Windows  Service  executes scheduled monitors and fires alerts and actions.

The Tray Icon  fires user interface alerts such as message box, sound, and system tray popups.

Implementation

Internet Server Monitor connects and interrogates network servers.  Alerts are fired based on monitor success
criteria, for example, Internet Server Monitor can fire an alert if the last 3 ping responses took more than 200ms
each.  Monitor results are saved to either a database or to file for later review within the user interface.

For more information, s ee:

Monitoring Servers

System Requirements

User Interface Components
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Tutorials
 

We are currently working on our tutorials.  Please be patient while we develop our tutorials available soon in our
upcoming builds.  Here are a few that we have completed:

Using Gmail as a Backup Email Server
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Using Gmail as a Backup Email Server
 

This tutorial will show you how to configure this software to use your Gmail account to send email alerts when
your primary email server is unavailable or unable to send.

To configure Gmail

From the Tools menu item select Options.

Select the Email tab.

At the bottom of the tab check Use a backup email server when this servers unavailable or unable to send.

Click the Configure Backup button.

You should now see the Configure Email Settings (Backup) dialog.  This dialog enables you to configure your
backup email server.  Specify the following values:

�x         Email server (SMTP): smtp.gmail.com:465
�x         Check Use Secure Socket Layer (SSL)

�x         Username: Enter your username excluding @gmail.com
�x         Password: Enter your password

�x         Once complete enter the email address you want to send the alert to.  Typically this would be your
Gmail account, for example, your_gmail_user_name@gmail.com.  

Click the Test button.

The packets will output to the Test Status window.  Once complete a message will popup that shows the
success or failure.

Log into your Gmail account and verify you received the test message.
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System Requirements
 

Supported Operating Systems

Windows Server 2008, 7, Vista, Server 2003 or XP. 

Supported CPUs

Our software is compiled with the latest version of the .Net Framework which allows us to compile the program
once for any CPU.  This means Internet Server Monitor can run natively on both 64-bit and 32-bit hardware.

Memory

1 GB of available memory, 2 GBs suggested for large networks.

.Net Framework 3.5

The installation detects if .Net Framework 3.5 is already installed. If not, the framework is automatically
downloaded from Microsoft and then installed.  Please note the framework takes a significant amount of time to
install.  Please be patient while the installation completes.

Domain A dministrator A ccount

To access network resources both the logged in user and the Windows Service must have domain administrator
rights.  The first time the application is run, you will be prompted to assign domain administrator credentials to
the service.

Windows Management Instrumentation (client and server)

CPU, memory and Windows Services are monitored using Microsoft's Windows Management Instrumentation
(WMI) API.  WMI is preinstalled on all supported operating systems but may require some configuration.

For more information, s ee:

How it Works
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Licensing and Registration
 

For more information, s ee:

Licensing

Registration
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Update Service
 

All or our software supports automatic updates. At startup, each of our user interfaces downloads an XML file
from our web server. Using version information, our software determines if an update is necessary. License
information may be transmitted to our registration web service, also running on web server, to determine upgrade
eligibility. If eligible, our software will download the latest version from our web server. 

Each license comes with access to updates and major releases for 1 year. After that, you can purchase a
maintenance contract that provides you access to updates and major releases for 1 more year.

For more information, s ee:

Licensing

Registration
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About Corner Bowl Software
 

Who We Are

Corner Bowl Software is a privately held company located in Park City, Utah, USA. We have been developing and
selling software specifically for Information Technology professionals for over 8 years now. Our products are
designed, developed, and continually updated in direct response to user feedback. All of our software tools are
developed and supported in Park City. 

Our Software

Corner Bowl Software offers software tools that enable System Administrators to monitor and maintain their
servers and workstations. We offer Event Log, text log, and Syslog management applications as well as disk
monitoring and server monitoring software tools.  We welcome you to evaluate our software tools and very much
appreciate feedback enabling us to update our applications to meet your demanding needs. 

Development Cycles

Corner Bowl Software prides itself on producing high quality usable software that utilizes the latest user interface
components. We receive feature requests on a daily basis and in response have implemented a development
system that enables us to quickly add, test, and release new features. Over the years we have worked closely
with System Administrators during audit cycles, such as those imposed by Sarbanes Oxley and PCI compliance
requirements, providing them with new features that enable them to more quickly respond to auditor requests.

How to Contact Us

Our Address

Corner Bowl Software
PO Box 682876
Park City, Utah 84068, USA

Support Inquiries

Email: support@cornerbowl.com

Phone: 1-866-543-9470

Sales Inquiries

Email: sales@cornerbowl.com

Phone: 1-866-501-8670
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Contact Information
 

Our Address

Corner Bowl Software
PO Box 682876
Park City, Utah 84068, USA

Support Inquiries

Email: support@cornerbowl.com

Phone: 1-866-543-9470

Sales Inquiries

Email: sales@cornerbowl.com

Phone: 1-866-501-8670

For more information, s ee:

Technical Support
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Best Practices
 

Monitor frequently but appropriately

Ping, CPU and memory monitors should be run a minimum of once a minute while other monitors such as HTTP
should be run slower.  Be aware HTTP monitors will affect your web site statistics.

Limit his tory for high frequency monitors

Each monitor result is saved to the history database or file.  If running a ping every second, you’ll want to limit the
history to as little as a single day or week.  If you save the history for longer than that the monitor detail forms
and documents may take significant time to generate.

Store monitor res ults  to SQL Server

In many cases history stored in SQL Server is retrieved and managed much faster than that of data stored in
MySQL or our file format.  If possible use SQL Server.
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User Interface Components
 

The Internet Server Monitor user interface is made up of several views that enable you to configure monitors, view
summary reports, view monitor detail and view output.

Monitors
This window enables you to navigate all configured monitors.  From this view you can:

�x         Create, modify, and remove monitors

�x         View the current status and any failure messages

�x         View monitor detail reports

�x         View group summary reports

�x         Clear failures

�x         Create and organize monitor groups

�x         Create monitor hierarchy

�x         Disable and re-enable monitors

For more information, see Monitoring Servers.

Output
This window displays application status messages.

Service Output
The Internet Server Monitor Windows Service writes status messages to a log file.  This view tails the log file and
displays each status message.  The log file is located in the following directory:

�x         Window XP/Server 2003 – c:\documents and settings\all users\application data\CornerBowl\Internet
Server Monitor\ismsrv.log

�x         Windows Server 2008/Vista: c:\programdata\ CornerBowl\Internet Server Monitor\ismsrv.log

For more information, s ee:

How it Works

Monitoring Servers 
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Actions, Alerts and Notifications
 

When a monitor fails or recovers an action, alert, or notification is fired.  By our definition actions, alerts and
notifications are one in the same.  Starting a process is more of an action than an alert while sending an email
notification is more of an alert or notification than an action, however; the software does not see these as different
hence the term alert and action are used interchangeably throughout the application and this help file.

The following actions are available:

Email Sends a simple notification message or a detailed message that
contains the filtered log entries.

Event Log Entry Writes the filtered log entries to a Windows Event Log.

Message Box Displays a message box that optionally includes the filtered log
entries.

Pager (SMS) Sends a text message using Clickatell’s web email-to-SMS online
gateway service or any third party email-to-SMS gateway.

Sound Plays a sound.

SNMP Trap Sends a SNMP trap via Microsoft’s SNMP Service.

Start Proces s Starts a background process.

Syslog Message Forwards each filtered log entry to a syslog server.

Tray Popup Displays a balloon window above the tray icon that optionally
includes the filtered log entries.

 

To create, modify, or remove an action

Select Configure Actions from the Tools menu item.

Use this dialog to create, modify, and remove actions.

To assign actions to a monitor

From the Monitors view, right click on the monitor and select Monitor Wizard.

When prompted, assign your alerts and actions.

To create nag alerts

Creating nag alerts requires you to configure the service to automatically clear the failure after a period of time. 
For example, if monitoring a web server every minute you can configure the service to fire an alert every 15
minutes while down.

From the Assign Alerts and Actions page within the Monitor Wizard check the option to automatically clear
failures then specify the period of time you want to elapse prior to clearing the failure.

An alert will be fired the next time the monitor fails.  For more information see Clearing Failures.

For more information s ee:

Clearing Failures

Monitor Wizard

Replacement Tags
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SNMP Traps
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Backing Up and Restoring the Configuration
 

The configuration information is stored in binary files located in the application data directory.

�x         Windows Server 2003/XP – c:\documents and settings\all users\application data\cornerbowl\Internet
Server Monitor

�x         Windows Server 2008/7/Vista – c:\program data\CornerBowl\Internet Server Monitor

To backup the current configurations  and settings

From the Tools menu item select Backup Configuration.

Select a destination directory and click OK.

All of the .DAT files within the application data directory will be immediately copied.

To restore from a backup s et of files

From the Tools menu bar select Restore Configuration.

Select the source directory and click OK.

All of the .DAT files within the source directory will be immediately copied.  The user interface will take a few
moments to load the restored configurations and settings.

 

NOTE:  When moving the installation to another computer these files can be transferred, however; the installation
directory and target OS should be identical as path information may be listed in any of the configuration files.  If
the paths are different be sure to reset the HTML templates and any other options that contain path information
within the Options dialog.
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Check Now
 

At any point in time you can check multiple monitors even if disabled or shutdown.  When manually checked,
failures states may be set and cleared however alerts and actions are not fired.  History is also saved.

To immediately check monitors

From the Monitors view check each monitor to run.

Select Check Selected Monitors from the Tools menu item.

The user interface will automatically fire off a thread for each monitor.  Once each monitor is complete the status
dialog will automatically close if there are no failures.  If there is a failure the dialog will remain open until you
close it.
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Clearing Failures
 

A failure occurs when a monitor either fails or errors.  In some cases the failure may be due to a load issue vs.
total failure.  Only one alert is fired in response to a monitor failing.  Failures are typically cleared when the
monitor detects the server is back online or the load has returned to normal.

If a monitor remains in a failed state for a period of time you may want to receive another alert reminding you of
the failure.  We call these nag alerts.  To do this you must configure the service to automatically clear the failure
after a period of time.  For example, if monitoring a web server every minute you can configure the service to fire
an alert every 15 minutes while down.

From the Assign Alerts and Actions page within the Monitor Wizard check the option to automatically clear
failures then specify the period of time you want to elapse prior to clearing the failure.

An alert will be fired the next time the monitor fails.

For more information, s ee:

Actions, Alerts and Notifications

Monitor Wizard
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Clone Monitor
 

If you have monitors you want to use on another server then you’ll want to use our Clone Monitor function.  The
clone monitor function copies a monitor in its entirety and places it within the same hierarchy within the monitor
tree.  Once cloned, open the Monitor Wizard to change the server the monitor is to be applied.  Upon saving the
changes use drag and drop to move the monitor to the appropriate group or parent monitor.

To clone a monitor

From the Monitors view right click on the monitor to clone and select Clone Monitor.

Specify the name of the new monitor.

Right click on the new monitor and select Monitor Wizard.

Make the necessary changes within the wizard and close the wizard.

Use drag and drop to move the monitor to the appropriate group or parent monitor. 

For more information, s ee:

Hierarchy

Monitor Wizard
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Command-Line Support
 

Internet Server Monitor enables you to execute monitors and perform management functions from the
command-line.  Please note user interface alerts such as Message Box actions cannot be fired from the
command-line.

 

Use:

ismcl [options] [ID]

 

Options

-r [ID]    Checks the specified monitor.

-x [ID]    Disables the specified monitor.

-e [ID]    Enables the specified monitor.

-a         Checks all monitors.

 

Parameters

[ID]       The ID of the monitor.  Monitor IDs can be viewed from the user interface by
selecting 'Command Line Information' from the 'View' menu item.

 

Example:

ismcl -r 3
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Group Summary
 

Although you can see the current status at a glace from the Monitors view, you can also view a detailed report of
each monitor per group.  This view enables you to see all current failures at a glance without opening each
monitor’s detail report.  If saving monitor results to your Web Server (configured via the Options dialog) you can
also view group summary reports from your Internet browser.  For more information see Web Server.

To view a group ’s summary report

Right click the group and select Group Summary.

For more information, s ee:

Groups

Options

Web Server
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Groups
 

To facilitate ease of navigation, configuration and monitoring, monitors can be grouped.

To create a group

Select New Group from the File menu item.  

Specify the group name and click OK.

To assign a monitor to a group

From the Navigation view use drag and drop to assign each monitor to the appropriate group.  

To assign multiple monitors at once 

From the Navigation view check each monitor to group.

Right click and select Monitor Wizard.

Select or add the group when prompted.

To rename a group

Select (highlight) the group and press F2.

Enter the new name and press the enter key.
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Hierarchy
 

Hierarchy rules enable you to enable, throttle, or disable a monitor based on another monitors alert state.  We
developed this functionality with 2 different scenarios in mind.

First, when a server goes down, system administrators typically do not want to receive notification for each
monitor running on the server but instead would rather see a single notification stating the server went down.

Second, when a server goes down, you may want to start or throttle up a monitor for the backup server.

To accomplish these requirements we added hierarchy support.  Hierarchy is accomplished by simply using drag
and drop from the Monitors view.

To create monitor hierarchy

From the Monitors view, select the parent monitor, right click and select New Monitor.   Your new monitor will be
created as a child of the currently selected monitor.  If your monitors have already been created you want to
re-assign dependencies use drag and drop to move each monitor to the target parent monitor.  

To shutdown monitors  when a server goes  down

Create a Ping monitor that runs every minute or less.

From the Monitors view right click on your new monitor and select New Monitor.  Create a monitor for each
network application you want to monitor, for example, HTTP and SMTP.  

Right click on the ping monitor and select Monitor Wizard from the File menu item.  Click through to the
Dependent Monitor Schedules tab.  Set the schedule for each child so the monitor is shutdown when the ping
monitor fails.  To do this check the Apply the following monitor frequency after the montior’s parent  fails option
followed by the Shutdown option.  See the screen shot below:

To apply monitor rules  for a backup s erver
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Follow the instruction above to create a ping and child network application monitors for the primary server.

Once created, create a second ping monitor for the backup server with a schedule of once every 5 minutes. 
Once complete create each child network application monitor.  This time when configuring the child monitors,
apply a slow schedule, for example once every 15 minutes.  Drag the backup server’s ping monitor and drop it on
the primary server’s ping monitor.

Right click on the backup server’s ping monitor and select Monitor Wizard from the File menu item.  Click through
to the Schedule Parameters page.  Throttle up the monitor frequency when the primary server fails.  To do this
check the Apply the following monitor frequency after the montior’s parent  fails option and specify a schedule of
once a minute.  The monitor will now run every 5 minutes until the primary server fails.  Once the primary server
fails, the monitor will run every minute.  See the screen shot below:

 

Click through to the Dependent Monitor Schedules page.  Throttle up the child monitor frequencies when the
primary server fails.  To do this select the child monitor and then check the Apply the following monitor frequency
after the monitor’s parent parent  fails option and specify a schedule of every 5 minutes.  See the screen shot
below:
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History
 

Every time a monitor is executed the results are saved.  Saved results are called history.  History can be stored
to either a database such as SQL Server or MySQL or to the file system.  By default history is saved to the file
system using a proprietary binary file format.  

To view a monitor ’s history

From the Monitors view, right click on the monitor and select Monitor Detail.  

Select the History tab.

To limit the amount of data s tored

By default all monitor results older than 3 days are automatically removed from the history once a day at 12:00
AM (00:00).  Use the Monitor Wizard to increase or decrease the number of days to store results.

To use SQL Server or MySQL to s tore his tory

Select Options from the Tools menu item.

Select the History tab.

From the Provider combo-box, select either SQL Server or MySQL.  Specify the connection parameters.

When using a database to store history you must first create the database and assign an account with owner
permissions to the database using the database specific administration tools. 

If you want to store the history to a remote location using our file format, use UNC when specifying the path (for
example, \\servername\c$\history) as the service may not have access to drive mappings.

When you are finished, click OK.

For more information, s ee:

Options

Monitor Wizard
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HTML Templates
 

Internet Server Monitor automatically creates HTML pages that contain an index of all groups and monitors, group
summary reports and monitor detail reports.  When a group is selected, a group summary report is displayed. 
When a monitor is selected, the monitor detailed report is displayed.  The output HTML is generated using our
HTML template files.  Create your own look and content by overriding our HTML templates.  

There are 3 different types of templates.  They are: an index, a logical group summary report, and a detailed
monitor report.  The templates are stored under the installation directory in a sub-directory called ‘html’.  The
default template filenames are: index.template, group.template, and monitor.template.  Please do not modify
these files.  The templates are HTML files that contain special section tags starting with the letters ‘CBS’.  Each
file contains replacement tags denoted with {}.  Please use the supplied templates as a basis for creating your
own templates.  

Index Template

The index template requires the <CBS_GROUP> and the <CBS_MONITOR> tags.  Please note the
<CBS_GROUP> tag must wrap the <CBS_MONITOR> tag.

Detail Index Summary

In addition to the default index template is another template that includes monitor detail within the index.  This
template is called index_detail.template.  Use this template when you want all the detail information found in the
group.template to be included in the index.  The index_detail template uses the <CBS_MONITOR> and
<CBS_MONITOR_ALT> tags to enable alternating background or font colors.  Please note the <CBS_GROUP>
tag must wrap the <CBS_MONITOR> and the <CBS_MONITOR_ALT> tags.  

NOTE: For performance reasons the detail index is only updated when a monitor either fails or recovers.

Summary and Detail Templates

The summary report and monitor detail report templates require the <CBS_MONITOR_ODD> and the
<CBS_MONITOR_EVEN> tags.  Use these tags to display monitor information in alternating formats.  For
example, a gray background on all even entries.

The following insertion tags are supported:

{SUMMARY_A_HREF} Inserts the URL to the index page.

{GROUP_IMG} Inserts the URL to the logical group image.

{GROUP_NAME} Inserts the name of the logical group.

{GROUP_STATUS} Inserts the logical group’s status as a string.

{GROUP_A_HREF} Inserts the URL to the logical group page.

{MONITOR_IMG}        Inserts the URL to the appropriate image that denotes the monitor’s
status.

{MONITOR_NAME} Inserts the monitor’s name.

{MONITOR_STATUS} Inserts the monitor’s status as a string.

{MONITOR_HOST} Inserts the host name associated with the monitor.

{MONITOR_TYPE} Inserts the type of monitor.  For example: HTTP or SMTP.

{MONITOR_TIME} Inserts the time the monitor executed.

{MONITOR_DURATION} Inserts the duration the monitor execution required.

{MONITOR_MESSAGE} Inserts the message the monitor execution saved.

{MONITOR_A_HREF} Inserts the URL to the monitors detail page.
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For more information s ee:

Options

Web Server
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Mapping Computers
 

The most common reason users map computers is to provide logon credentials, however; computers online but
undiscoverable can also be specified.

To map a computer

From the File menu item select Monitor Wizard.

Select the monitor type you want to monitor and click Next.

If selecting a WMI dependent monitor such as CPU, Memory, or Windows Services specify the logon credentials
now.

To modify login credentials

If the login credentials change, for example the password changes, open the Monitor Wizard for any of the WMI
dependent monitors and change the credentials within the wizard.  Once changed, all WMI dependent monitors
will be updated.

To remove a mapping

Mappings are automatically removed when all monitors are removed or the username field is cleared via the 
Monitor Wizard.

For more information, s ee:

Security
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Monitor Detail
 

The monitor detail enables users to review the current status, the current schedule being applied and the last
1000 history records.  If saving monitor results to your Web Server (configured via the Options dialog) you can
also view monitor detail reports from your Internet browser.  For more information see Web Server.

To modify the monitor

If you want to change the monitor configuration parameters click the Monitor Wizard button.

To test the monitor

From this form you can manually check the monitor.  When manually checked, failures states may be set and
cleared however alerts and actions are not fired.  History is also saved.

To clear failures

If a monitor is in a failed state, you can manually clear the failure by clicking on the Clear Failure button.  Once
cleared, the next failure will generate an alert.

To clear the his tory

If you have a significant amount of history which you are no longer interested in you can remove the data from the
database or file system by clicking the Clear History button.  You can also limit the number of days to store via
the Monitor Wizard.  When configured via the Monitor Wizard the database tables and/or files are automatically
truncated on a daily basis at 12:00 AM (00:00).  For more information see History.

To hide informational res ults

If you are only interested in failures, check the Only show failures checkbox.  The history view will be re-populated
with the last 1000 failure results.

Ping Monitor Detail
The ping monitor detail form includes extra functionality that enables you to watch ping times in real-time as well
as graphically view history results over time.

CPU Monitor Detail
The CPU monitor detail form includes extra functionality that enables you to watch CPU load for each CPU in
real-time as well as graphically view history results over time.

Memory Monitor Detail
The memory monitor detail form includes extra functionality that enables you to watch physical memory load in
real-time as well as graphically view history results over time.

For more information s ee:

History

Options

Monitor Wizard

Web Server

Page  30



 

Page  31



Monitor Wizard
 

As expected the Monitor Wizard provides the controls to configure and schedule your monitors.

To Create a New Monitor

Select New Monitor from the File menu item.

To Re-Configure Monitors

From the Monitors view, check each monitor to re-configure.

From the File menu item select Monitor Wizard.

When re-configuring multiple monitors at once use the Monitors combo-box at the top of the wizard to fine tune
specific monitor parameters or to quickly apply settings to all selected monitors at once. For example, to apply
the same action to multiple monitors, select (All), click through to the Assign Alerts and Actions page, lastly,
double-click on the alert or action to apply.

General Properties
The General Properties page enables you to select a monitor type, for example HTTP or SMTP, specify a name,
assign the monitor to a group, set the maximum number of days to store history, and set a retry count.

NOTE: Changes to the name or group are not reflected in the Monitors combo-box until the next time the Monitor
Wizard is opened.

NOTE: CPU, memory, and Windows Services monitors do not support retry count.

Monitor Parameters
The Monitor Parameters tab is specific to each type of monitor and contains all the controls necessary to setup
the appropriate parameters.

Schedule Parameters
The Schedule tab enables you to specify up to 4 different schedules. 

�x         Normal
�x         On Failure
�x         On Parent Failure
�x         On Parent Parent’s Failure

NOTE:  On parent failure is only available when the monitor is a child.  On parent parent’s failure is only available
when the monitor is at least 2 levels deep.  For more information see Hierarchy.

Assign Alerts and Actions
Use the Assign Alerts and Actions tab to assign alerts and actions as well as configure the service to
automatically clear failures.  For more information see Clearing Failures.

Dependent Monitor Schedules
When using monitor hierarchy, use the Dependent Monitor Schedules page as an alternate method to configure
the child monitor schedules.  For more information see Hierarchy.

 
For more information, s ee:
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Clearing Failures

Hierarchy

Monitoring Servers
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Monitoring Servers
 

Monitors enable you to receive notification when a server or a network application running on the server has
failed.  For example, you can monitor the availability of a server by creating a Ping monitor while also creating a
SMTP or mail monitor on the server which optionally sends an email.  If either monitor fails an alert is fired or
action executed.

In many cases you may want to throttle specific monitors in response to monitor failing.  For example, if a ping
monitor fails you can increase the ping frequency to a backup server.  For more information see Hierarchy.

Logically grouping similar or relevant monitors into groups enables you to simplify configuration and provides the
grouping for summary reports.  For more information see Groups.

To create a monitor

Select New Monitors from the File menu.

Follow the wizard.  For more information see Monitor Wizard.

To modify a monitor

From the Monitors view, select the monitor, right click and select Properties.

Follow the wizard.  For more information see Monitor Wizard.

To delete a monitor

From the Monitor view, select the monitor, right click and select Delete.

For more information, s ee:

Groups

Hierarchy

Monitor Wizard

Options
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Options
 

Email

Server Information

Specify the name of the SMTP server. For example: mail.yourserver.com.  If your server runs on a port other than
25, for example 2000, use the following format:  mail.yourserver.com:2000

Logon Information

If your SMTP server requires authentication to send messages, specify your username and password.

From Information

Optionally, specify the name and from address to appear in outgoing mail.

Email Limiter (Spam Control)

The email limiter enables you to limit the number of emails sent over a period of time.  When an email is dropped
a message is logged to the service log file.

Backup Email Server

Check this option and click the Configure Backup to configure an alternate email server to use when your primary
email server is unavailable or unable to send your email alert.

Testing Settings

When ever you change the mail server settings, it is a good idea to test the settings. To test the server and
account settings, specify a test email address then click the Send Test Email button.

History
The history is stored to either a SQL Server or MySQL database or the local file system using our proprietary
binary file format.  Use this tab to set the data provider and assign database connection parameters or the file
system location.  

When using a database to store history you must first create the database and assign an account with owner
permissions to the database using the database specific administration tools. 

If you want to store the history to a remote location using our file format, use UNC when specifying the path (for
example, \\servername\c$\history) as the service may not have access to drive mappings.

Web Server
Internet Server Monitor automatically creates HTML pages that contain an index of all groups and monitors, group
summary reports and monitor detail reports.  When a group is selected from the index, the group summary report
is displayed.  When a monitor is selected from the index or group summary, the monitor detailed report is
displayed.

Use the Web Server tab within the Options dialog to enable web server output, override the output directory or
override the HTML template files used during generation.

Web Server Output Schedule

If you only have a few monitors or the monitor frequency is set to a minutes schedule select the RealTime
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option.  Otherwise, select Scheduled. The scheduled option enables the software to minimize file IO while
maintaining fresh content.    

To change the location to output the HTML files

Select Options from the Tools menu item.  Select the Web Server tab.

Specify the location to output the HTML files.  If specifying a remote location, use UNC when specifying the path
(for example, \\servername\c$\history) as the service may not have access to drive mappings.

HTML Templates

The output HTML is generated using our HTML template files.  Create your own look and content by overriding our
HTML templates.  For more information see HTML Templates.

User Preferences

Tray Icon

The tray icon is responsible for firing user interface actions such as message box and tray icon popups.  If you
are running this software on a server and do not use user interface actions, you can save system memory by
disabling the tray icon.

For more information s ee:

HTML Templates

Web Server
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Replacement Tags
 

Replacement tags are used to insert variable values when firing actions.  When necessary each tag is parsed out
and replaced with the appropriate value.  The available replacement tags depend on the current functionality that
is running.  

The following tags are supported when:

�x         firing actions on behalf of scheduled monitor failing or recovering.

{FULLNAME} The group name followed by the monitor name

{NAME} The user friendly monitor name

{GROUP>} The group name

{HOST} The host name associated with the monitor

{DATE} The current date

{TIME} The current time

{DURATION} The amount of time required to process the monitor

{MESSAGE} The success or error message

{TYPE} The type of monitor being executed.  For example, HTTP or SMTP.

{LOCALHOST} The host name of the machine the software is installed.

For more information s ee:

Actions, Alerts and Notifications

Monitor Wizard 
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Schedules
 

Throughout Internet Server Monitor you are prompted to specify schedules.  Most commonly you are prompted to
schedule monitor frequencies.

The schedule dialog offers several different types of frequencies.  Some of the frequencies support exclusion time
periods.  For example, you can configure monitors to run Monday – Friday every hour excluding 12:00 AM – 2:00
AM.  The table below lists the supported frequencies and available exclusion options.

Frequency Description Day Exclus ion Time Exclus ion

Minutes Executes every X minutes. X X

Hourly Executes every X hours X
minutes after the hour.

X X

Daily Executes every day at XX:XX X  

Weekly Executes one day a week at
XX:XX 

  

Monthly Executes one day a month at
XX:XX
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SNMP Traps
 

Internet Server Monitor enables you to fire SNMP traps via Microsoft’s SNMP Service.  SNMP Traps enable you
to receive event notification within SNMP management applications such as HP OpenView.  

Prior to configuring an SNMP Trap action you must first install and configure Microsoft’s SNMP Windows
Component.  When you create an SNMP Trap action, Internet Server Monitor verifies the SNMP Service is
installed and adds all necessary registry keys to properly interface with Microsoft’s SNMP Service.  

For more information s ee:

Actions, Alerts and Notifications

Configuring the SNMP Service
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Tray Icon
 

Icons in the lower right corner of Windows Taskbar are called Tray Icons. Tray Icons display application status.
The Internet Server Monitor tray icon has three states:

 Service Running

This is the normal state.

 Alert State Set

At least one monitor has failed.

 Service Stopped

This state indicates the Internet Server Monitor Service is not running. Either use the Windows Service Control
Manager or the user interface to turn the service on. Once running, the icon will change to the Service Running
state.

To temporarily turn the tray icon off

From the Service menu item select Close Tray Icon.

NOTE:  Message box, tray popup messages, and sound actions will no longer fire.

To temporarily turn the tray icon on

Select Start Tray Icon from the Service menu.

To permanently disable or re-enable the tray icon 

From the Tools menu item select Options.

Select the User Preferences tab.

Check the option to disable or un-check to re-enable.
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User Interface Components
 

The Internet Server Monitor user interface is made up of several views that enable you to configure monitors, view
summary reports, view monitor detail and view output.

Monitors
This window enables you to navigate all configured monitors.  From this view you can:

�x         Create, modify, and remove monitors

�x         View the current status and any failure messages

�x         View monitor detail reports

�x         View group summary reports

�x         Clear failures

�x         Create and organize monitor groups

�x         Create monitor hierarchy

�x         Disable and re-enable monitors

For more information, see Monitoring Servers.

Output
This window displays application status messages.

Service Output
The Internet Server Monitor Windows Service writes status messages to a log file.  This view tails the log file and
displays each status message.  The log file is located in the following directory:

�x         Window XP/Server 2003 – c:\documents and settings\all users\application data\CornerBowl\Internet
Server Monitor\ismsrv.log

�x         Windows Server 2008/Vista: c:\programdata\ CornerBowl\Internet Server Monitor\ismsrv.log

For more information, s ee:

How it Works

Monitoring Servers 
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Web Proxy Server Configuration
 

Internet Server Monitor communicates over HTTP when querying our servers for updates and when registering
your license.  If your network requires you to use a web proxy server when communicating over HTTP you will
need to specify your proxy server settings.

To configure your proxy server settings

Select Register from the Help menu item.

Click the Configure Web Proxy button.

Use the Configure Web Proxy Server Settings dialog to enable or disable the proxy, specify the host and port,
and lastly specify the authentication settings.
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Web Server
 

Internet Server Monitor automatically creates HTML pages that contain an index of all groups and monitors, group
summary reports and monitor detail reports.  When a group is selected, a group summary report is displayed. 
When a monitor is selected, the monitor detailed report is displayed.

To enable web s erver output

Select Options from the Tools menu item.  Select the Web Server tab.

From the Web server output combo-box select RealTime or Scheduled.  Use RealTime when you only have a
small number of monitors or the monitor frequency is larger than 1 minute.  Use the Scheduled option when you
have a large number of monitors or monitoring every few seconds.  The Scheduled option minimizes file IO while
maintaining fresh content.    

To view the output via your Internet brows er

Using your Internet browser, open the index.html or [group].html found in your HTML output directory.  By default
the files are located in:

�x         Windows XP/Server 2003/2000 - c:\documents and settings\all users\application
data\CornerBowl\Internet Server Monitor\html 

�x         Windows Server 2008/7/Vista - c:\program data\CornerBowl\Internet Server Monitor\html

To change the output location 

Select Options from the Tools menu item.  Select the Web Server tab.

Specify the location to output the HTML files.  If specifying a remote location, use UNC when specifying the path
(for example, \\servername\c$\history) as the service may not have access to drive mappings.

To override the look and content

Select Options from the Tools menu item.  Select the Web Server tab.

Specify the HTML templates to use.  For more information see HTML Templates.

To disable automatic HTML document generation

Select Options from the Tools menu item.  Select the Web Server tab.

De-select the Export monitor detail to your web server option.

For more information s ee:

HTML Templates

Options
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Options
 

Email

Server Information

Specify the name of the SMTP server. For example: mail.yourserver.com.  If your server runs on a port other than
25, for example 2000, use the following format:  mail.yourserver.com:2000

Logon Information

If your SMTP server requires authentication to send messages, specify your username and password.

From Information

Optionally, specify the name and from address to appear in outgoing mail.

Email Limiter (Spam Control)

The email limiter enables you to limit the number of emails sent over a period of time.  When an email is dropped
a message is logged to the service log file.

Backup Email Server

Check this option and click the Configure Backup to configure an alternate email server to use when your primary
email server is unavailable or unable to send your email alert.

Testing Settings

When ever you change the mail server settings, it is a good idea to test the settings. To test the server and
account settings, specify a test email address then click the Send Test Email button.

History
The history is stored to either a SQL Server or MySQL database or the local file system using our proprietary
binary file format.  Use this tab to set the data provider and assign database connection parameters or the file
system location.  

When using a database to store history you must first create the database and assign an account with owner
permissions to the database using the database specific administration tools. 

If you want to store the history to a remote location using our file format, use UNC when specifying the path (for
example, \\servername\c$\history) as the service may not have access to drive mappings.

Web Server
Internet Server Monitor automatically creates HTML pages that contain an index of all groups and monitors, group
summary reports and monitor detail reports.  When a group is selected from the index, the group summary report
is displayed.  When a monitor is selected from the index or group summary, the monitor detailed report is
displayed.

Use the Web Server tab within the Options dialog to enable web server output, override the output directory or
override the HTML template files used during generation.

Web Server Output Schedule

If you only have a few monitors or the monitor frequency is set to a minutes schedule select the RealTime
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option.  Otherwise, select Scheduled. The scheduled option enables the software to minimize file IO while
maintaining fresh content.    

To change the location to output the HTML files

Select Options from the Tools menu item.  Select the Web Server tab.

Specify the location to output the HTML files.  If specifying a remote location, use UNC when specifying the path
(for example, \\servername\c$\history) as the service may not have access to drive mappings.

HTML Templates

The output HTML is generated using our HTML template files.  Create your own look and content by overriding our
HTML templates.  For more information see HTML Templates.

User Preferences

Tray Icon

The tray icon is responsible for firing user interface actions such as message box and tray icon popups.  If you
are running this software on a server and do not use user interface actions, you can save system memory by
disabling the tray icon.

For more information s ee:

HTML Templates

Web Server
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Options
 

Email

Server Information

Specify the name of the SMTP server. For example: mail.yourserver.com.  If your server runs on a port other than
25, for example 2000, use the following format:  mail.yourserver.com:2000

Logon Information

If your SMTP server requires authentication to send messages, specify your username and password.

From Information

Optionally, specify the name and from address to appear in outgoing mail.

Email Limiter (Spam Control)

The email limiter enables you to limit the number of emails sent over a period of time.  When an email is dropped
a message is logged to the service log file.

Backup Email Server

Check this option and click the Configure Backup to configure an alternate email server to use when your primary
email server is unavailable or unable to send your email alert.

Testing Settings

When ever you change the mail server settings, it is a good idea to test the settings. To test the server and
account settings, specify a test email address then click the Send Test Email button.

History
The history is stored to either a SQL Server or MySQL database or the local file system using our proprietary
binary file format.  Use this tab to set the data provider and assign database connection parameters or the file
system location.  

When using a database to store history you must first create the database and assign an account with owner
permissions to the database using the database specific administration tools. 

If you want to store the history to a remote location using our file format, use UNC when specifying the path (for
example, \\servername\c$\history) as the service may not have access to drive mappings.

Web Server
Internet Server Monitor automatically creates HTML pages that contain an index of all groups and monitors, group
summary reports and monitor detail reports.  When a group is selected from the index, the group summary report
is displayed.  When a monitor is selected from the index or group summary, the monitor detailed report is
displayed.

Use the Web Server tab within the Options dialog to enable web server output, override the output directory or
override the HTML template files used during generation.

Web Server Output Schedule

If you only have a few monitors or the monitor frequency is set to a minutes schedule select the RealTime
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option.  Otherwise, select Scheduled. The scheduled option enables the software to minimize file IO while
maintaining fresh content.    

To change the location to output the HTML files

Select Options from the Tools menu item.  Select the Web Server tab.

Specify the location to output the HTML files.  If specifying a remote location, use UNC when specifying the path
(for example, \\servername\c$\history) as the service may not have access to drive mappings.

HTML Templates

The output HTML is generated using our HTML template files.  Create your own look and content by overriding our
HTML templates.  For more information see HTML Templates.

User Preferences

Tray Icon

The tray icon is responsible for firing user interface actions such as message box and tray icon popups.  If you
are running this software on a server and do not use user interface actions, you can save system memory by
disabling the tray icon.

For more information s ee:

HTML Templates

Web Server
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Options
 

Email

Server Information

Specify the name of the SMTP server. For example: mail.yourserver.com.  If your server runs on a port other than
25, for example 2000, use the following format:  mail.yourserver.com:2000

Logon Information

If your SMTP server requires authentication to send messages, specify your username and password.

From Information

Optionally, specify the name and from address to appear in outgoing mail.

Email Limiter (Spam Control)

The email limiter enables you to limit the number of emails sent over a period of time.  When an email is dropped
a message is logged to the service log file.

Backup Email Server

Check this option and click the Configure Backup to configure an alternate email server to use when your primary
email server is unavailable or unable to send your email alert.

Testing Settings

When ever you change the mail server settings, it is a good idea to test the settings. To test the server and
account settings, specify a test email address then click the Send Test Email button.

History
The history is stored to either a SQL Server or MySQL database or the local file system using our proprietary
binary file format.  Use this tab to set the data provider and assign database connection parameters or the file
system location.  

When using a database to store history you must first create the database and assign an account with owner
permissions to the database using the database specific administration tools. 

If you want to store the history to a remote location using our file format, use UNC when specifying the path (for
example, \\servername\c$\history) as the service may not have access to drive mappings.

Web Server
Internet Server Monitor automatically creates HTML pages that contain an index of all groups and monitors, group
summary reports and monitor detail reports.  When a group is selected from the index, the group summary report
is displayed.  When a monitor is selected from the index or group summary, the monitor detailed report is
displayed.

Use the Web Server tab within the Options dialog to enable web server output, override the output directory or
override the HTML template files used during generation.

Web Server Output Schedule

If you only have a few monitors or the monitor frequency is set to a minutes schedule select the RealTime
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option.  Otherwise, select Scheduled. The scheduled option enables the software to minimize file IO while
maintaining fresh content.    

To change the location to output the HTML files

Select Options from the Tools menu item.  Select the Web Server tab.

Specify the location to output the HTML files.  If specifying a remote location, use UNC when specifying the path
(for example, \\servername\c$\history) as the service may not have access to drive mappings.

HTML Templates

The output HTML is generated using our HTML template files.  Create your own look and content by overriding our
HTML templates.  For more information see HTML Templates.

User Preferences

Tray Icon

The tray icon is responsible for firing user interface actions such as message box and tray icon popups.  If you
are running this software on a server and do not use user interface actions, you can save system memory by
disabling the tray icon.

For more information s ee:

HTML Templates

Web Server
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Options
 

Email

Server Information

Specify the name of the SMTP server. For example: mail.yourserver.com.  If your server runs on a port other than
25, for example 2000, use the following format:  mail.yourserver.com:2000

Logon Information

If your SMTP server requires authentication to send messages, specify your username and password.

From Information

Optionally, specify the name and from address to appear in outgoing mail.

Email Limiter (Spam Control)

The email limiter enables you to limit the number of emails sent over a period of time.  When an email is dropped
a message is logged to the service log file.

Backup Email Server

Check this option and click the Configure Backup to configure an alternate email server to use when your primary
email server is unavailable or unable to send your email alert.

Testing Settings

When ever you change the mail server settings, it is a good idea to test the settings. To test the server and
account settings, specify a test email address then click the Send Test Email button.

History
The history is stored to either a SQL Server or MySQL database or the local file system using our proprietary
binary file format.  Use this tab to set the data provider and assign database connection parameters or the file
system location.  

When using a database to store history you must first create the database and assign an account with owner
permissions to the database using the database specific administration tools. 

If you want to store the history to a remote location using our file format, use UNC when specifying the path (for
example, \\servername\c$\history) as the service may not have access to drive mappings.

Web Server
Internet Server Monitor automatically creates HTML pages that contain an index of all groups and monitors, group
summary reports and monitor detail reports.  When a group is selected from the index, the group summary report
is displayed.  When a monitor is selected from the index or group summary, the monitor detailed report is
displayed.

Use the Web Server tab within the Options dialog to enable web server output, override the output directory or
override the HTML template files used during generation.

Web Server Output Schedule

If you only have a few monitors or the monitor frequency is set to a minutes schedule select the RealTime
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option.  Otherwise, select Scheduled. The scheduled option enables the software to minimize file IO while
maintaining fresh content.    

To change the location to output the HTML files

Select Options from the Tools menu item.  Select the Web Server tab.

Specify the location to output the HTML files.  If specifying a remote location, use UNC when specifying the path
(for example, \\servername\c$\history) as the service may not have access to drive mappings.

HTML Templates

The output HTML is generated using our HTML template files.  Create your own look and content by overriding our
HTML templates.  For more information see HTML Templates.

User Preferences

Tray Icon

The tray icon is responsible for firing user interface actions such as message box and tray icon popups.  If you
are running this software on a server and do not use user interface actions, you can save system memory by
disabling the tray icon.

For more information s ee:

HTML Templates

Web Server
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Options
 

Email

Server Information

Specify the name of the SMTP server. For example: mail.yourserver.com.  If your server runs on a port other than
25, for example 2000, use the following format:  mail.yourserver.com:2000

Logon Information

If your SMTP server requires authentication to send messages, specify your username and password.

From Information

Optionally, specify the name and from address to appear in outgoing mail.

Email Limiter (Spam Control)

The email limiter enables you to limit the number of emails sent over a period of time.  When an email is dropped
a message is logged to the service log file.

Backup Email Server

Check this option and click the Configure Backup to configure an alternate email server to use when your primary
email server is unavailable or unable to send your email alert.

Testing Settings

When ever you change the mail server settings, it is a good idea to test the settings. To test the server and
account settings, specify a test email address then click the Send Test Email button.

History
The history is stored to either a SQL Server or MySQL database or the local file system using our proprietary
binary file format.  Use this tab to set the data provider and assign database connection parameters or the file
system location.  

When using a database to store history you must first create the database and assign an account with owner
permissions to the database using the database specific administration tools. 

If you want to store the history to a remote location using our file format, use UNC when specifying the path (for
example, \\servername\c$\history) as the service may not have access to drive mappings.

Web Server
Internet Server Monitor automatically creates HTML pages that contain an index of all groups and monitors, group
summary reports and monitor detail reports.  When a group is selected from the index, the group summary report
is displayed.  When a monitor is selected from the index or group summary, the monitor detailed report is
displayed.

Use the Web Server tab within the Options dialog to enable web server output, override the output directory or
override the HTML template files used during generation.

Web Server Output Schedule

If you only have a few monitors or the monitor frequency is set to a minutes schedule select the RealTime
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option.  Otherwise, select Scheduled. The scheduled option enables the software to minimize file IO while
maintaining fresh content.    

To change the location to output the HTML files

Select Options from the Tools menu item.  Select the Web Server tab.

Specify the location to output the HTML files.  If specifying a remote location, use UNC when specifying the path
(for example, \\servername\c$\history) as the service may not have access to drive mappings.

HTML Templates

The output HTML is generated using our HTML template files.  Create your own look and content by overriding our
HTML templates.  For more information see HTML Templates.

User Preferences

Tray Icon

The tray icon is responsible for firing user interface actions such as message box and tray icon popups.  If you
are running this software on a server and do not use user interface actions, you can save system memory by
disabling the tray icon.

For more information s ee:

HTML Templates

Web Server
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Windows Service
 

Internet Server Monitor uses a service to run scheduled monitors. This service is called Corner Bowl Internet
Server Monitor.

For more information, s ee:

Change Service Logon

Windows Service Log File

Starting and Stopping the Windows Service
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Change Service Logon
 

Internet Server Monitor uses a service to run scheduled monitors. This service is called Corner Bowl Internet
Server Monitor.

In order for the Internet Server Monitor Service to access network resources, it must run with domain
administrator rights. 

To change the service logon credentials

From the Service menu item select Change Service Logon.

Specify a domain administrator username and password. Lastly, specify the domain. When you are finished,
click the Next button. The service configuration will be modified with these rights and the service restarted.

For more information, s ee:

Security

Windows Service
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Windows Service Log File
 

Internet Server Monitor uses a service to run scheduled monitors. This service is called Corner Bowl Internet
Server Monitor.

The Internet Server Monitor Service logs all significant activity to a log file called 'ismsrv.log'. This information is
invaluable when troubleshooting the service.  This file is located in the installation directory. The default location
is:

�x         Windows Server 2003/XP – c:\documents and settings\all users\application data\CornerBowl\Internet
Server Monitor\ismsrv.log

�x         Windows Server 2008/7/Windows Vista – c:\programdata\CornerBowl\Internet Server Monitor\ismsrv.log 

To View the Log File

From the Service menu item select View Service Log.

The entries are sorted from oldest to latest. The log file can also be viewed in any text editor. 

To Clear the Log File

The service automatically truncates the log file to a little less than 1 MB every hour on the hour. The service will
log a notice message when attempting to truncate the log file if the user interface is open. To manually clear or
delete the entire log file, the service must be stopped and the user interface closed. Once the service is stopped
and the user interface is closed, manually delete the log file. After the file has been deleted, re-start the service. 

For more information, see:

Starting and Stopping the Windows Service

Windows Service
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Starting and Stopping the Windows Service
 

Internet Server Monitor uses a service to run scheduled monitors. This service is called Corner Bowl Internet
Server Monitor.

To Start the Service

From the Service menu item select Start.

If you are unable to start the service because of a logon failure, you must reset the logon credentials. For more
information see Change Service Logon.

To Start the Service in Verbose Mode

To aid in troubleshooting, the service can be started in verbose (debug) mode. In this mode, extra messages are
logged.  From the Service menu item select Start Verbose.

To Stop the Service

From the Service menu item select Stop.

For more information, s ee:

Change Service Logon

Windows Service Log File

Windows Service
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Troubleshooting
 

Please select from the list of links that most closely relates to your issue:

Receiving Error: The RPC Server is Unavailable

Receiving Error: Access Denied

Unable to Get Actions, Alerts or Notifications to Work
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Common Monitor Issues
 

NOTE: Many errors can be easily resolved by reviewing the service log file.  To view the service log file select
View Log from the Service menu item.

Internet Server Monitor uses a Microsoft technology known as Windows Management Instrumentation (WMI) to
monitor CPU load, memory load and Windows Services.  The most common error reported by the operating
system for WMI problems are:

�x         The RPC server is unavailable
�x         Access Denied

We have found it is beneficial to tell customers to first verify the connection or access failure from within the WMI
Control Panel on the computer Internet Server Monitor is installed.  

Connecting to a remote computer within the WMI Control Panel

From the run menu or a command-prompt, type: wmimgmt.msc.  This command will open the WMI Control Panel
within the Microsoft Management Console (MMC).  

Right click on the WMI Control (Local) node located in the left pane.  Select Connect to another computer.  If
running on an OS prior to Windows Vista, you have the option to specify credentials.  If running on Vista, you no
longer have this option.  Specify credentials as necessary.  Lastly, click OK.  

Once the dialog closes, right click on the WMI Control node again and select Properties.  Most users will receive
the RPC server is unavailable or access denied error at this point.

The RPC Server is Unavailable
Typically an RPC error means the remote computer is not allowing WMI packets through its firewall or the remote
computer does not allow remote administration.  The Windows Firewall or virus protection software can all block
WMI packets.

If you think the remote computer’s Windows Firewall is blocking WMI packets or remote administration is not
enabled, please follow this link for more information:  

Configuring the Windows Firewall

Otherwise, please continue reading the sections labeled Access Denied and Other Things to Look At below.  If
you are still unable to resolve the error, please read the following MSDN articles:

Connecting to WMI Remotely Starting with Vista 

Securing a Remote WMI Connection

Access Denied
Typically an access denied error means the account you are logged in under or the account the Windows Service
is running under does not have the appropriate credentials to access the WMI data.

1.  If reading data from another computer on the network, make sure that the account you are logged in as and
the account the service is running under both have administrative privileges.  For more information see Security.  If
the account you are logged in does not have administrator rights or you are attempting to access a computer not
on the domain, you must map the computer to specify the appropriate credentials.  For more information see 
Mapping Computers.

2.  Ensure WMI permissions have been set correctly.  From the remote computer throwing the error, open a
command-prompt and type: wmimgmt.msc.  Right click on the WMI Control (local) node and select Properties. 
Select the Security tab and navigate to root/CIMV2.  Click the Security button.  Grant the account you and the
service are using to access the data Remote Enable and Read Security rights.
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3.  When accessing a Windows Vista computer that has joined a workgroup rather than a domain, the remote
Windows Vista computer must disable User Access Control (UAC).  To disable UAC on a Windows Vista
computer, search for Turn UAC off within the Windows help system.

Other Things to Look At
1. If you have other internal firewalls on your network, you may need to configure them to allow WMI packets. 
Many virus protection solutions such as McAfee and Symantec contain their own firewalls which must be
configured to allow WMI packets. 

2.  If the remote computer is running Windows XP Pro, make sure remote logons are not being coerced to the
GUEST account.  From the computer you are unable to download logs from, open a command-prompt and type 
secpol.msc.  Expand the Local Policies node and select Security Options.  Scroll down to the setting titled
Network access: Sharing and security model for local accounts.  If this is set to Guest only, change it to Classic
and restart your computer. 

3.  From the computer you are unable to download logs from, open a command-prompt and type dcomcnfg. 
Expand the Component Services/Computers/My Computer node.  Right click My Computer and then select
Properties.  Select the COM Security tab.  From the Launch and Activation Permissions, select Edit Limits.  Add
the appropriate account and assign all permissions.

4.  Check that DCOM is enabled on both the local and the remote computer.  Check the following registry value
on both computers: Key: HKLM\Software\Microsoft\OLE, value: EnableDCOM, should be set to 'Y' 

5.  Check that WMI is installed on both the local and remote computer.  WMI is present by default in all flavors of
Windows 2000 and later operating systems, but must be installed manually on NT4 systems.  To check for the
presence of WMI, open a command-prompt and type wbemtest.  If the WMI Tester application starts up, WMI is
present, if not, it must be installed.  Consult Microsoft for more information.

6. Make sure no remote access or WMI-related services have been disabled on either the local or remote
computer.  On an XP machine, the following services should be running or enabled: 

�x         COM+ Event System 
�x         Remote Access Auto Connection Manager 
�x         Remote Access Connection Manager 
�x         Remote Procedure Call (RPC) 
�x         Remote Procedure Call (RPC) Locator 
�x         Remote Registry Server 
�x         Windows Management Instrumentation 
�x         Windows Management Instrumentation Driver Extensions 
�x         WMI Performance Adapter 
�x         Workstation 

For more information, s ee:

Troubleshooting

Security

Mapping Computers

Connecting to WMI Remotely Starting with Vista 

Securing a Remote WMI Connection

Common Action Issues
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Common Action Issues
 

I’m not receiving my emails?

Typically the email server has not been setup correctly.  Select Options from the Tools menu item and select
the Email tab.  If using Windows Authentication mode, make sure the account the service is running under can
log onto the domain.  If the service is running under the SYSTEM account you will not be able to send emails
using Windows Authentication.  If the email parameters are setup correctly and the service is running with the
appropriate credentials, verify the alert is cleared prior to the monitor running.  

I’m not receiving my desktop alert notifications?

The tray icon executable must be running.  Select Start Tray Icon from the Service menu item.  If the tray icon is
already running, verify the alert is cleared prior to the monitor running. 

 

NOTE: Many errors can be easily resolved by reviewing the service log file.  To view the service log file select
View Log from the Service menu item.

For more information, s ee:

Troubleshooting
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Security
 

Event Logs

To access remote Event Logs from the user interface, your login must have domain administrator rights.  If your
account does not have domain administrator rights, you can map a computer and specify login credentials that
enable you to read remote Security Event Logs.  For more information see Mapping Computers.

When real-time monitoring or consolidating remote Event Logs, the service must be run with domain administrator
credentials.  The first time the application is run, you will be prompted to assign domain administrator credentials
to the service.  When the password assigned to the account the service is running under changes, you must
update the service to use the latest password. For more information see Change Service Logon. 

If you are receiving an RPC or Access Denied error please see Troubleshooting.

Text Logs

When monitoring text log files, be sure all remote log files are accessed using UNC paths as  Windows Services
are unable to access Mapped disk drives.

For more information, s ee:

Change Service Logon

Mapping Computers

Troubleshooting
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Configuring the Windows Firewall
 

Windows Server 2008, 7, Vista, Server 2003 SP1, and XP SP2 include the Windows Firewall which, depending
on the OS version, my block WMI traffic by default. If WMI traffic is blocked, Internet Server Monitor will typically
throw an RPC server error. 

In order to allow access you must enable Windows Management Instrumentation (WMI) or Remote
Administration.  The simplest way to do this is to open up a command prompt and type the following: 

Windows  Server 2008/7/Vis ta:

netsh advfirewall firewall set rule group="windows management instrumentation (wmi)" new
enable=yes

Windows Server 2003/XP: 

netsh firewall set service RemoteAdmin

The effect is immediate and there is no need to restart.  To read more about this, consult the following Microsoft
articles: 

Server 2008/7/Vista

Server 2003/XP

 

If you are still unable to download or monitor remote logs see Troubleshooting.

For more information, see:

Security

Troubleshooting
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Technical Support
 

If you have any problems with Internet Server Monitor you can contact our tech support by emailing us at:

support@cornerbowl.com

Please make sure you tell us as much information as you can about the problem you are experiencing, including
any error or warning messages that may have been displayed.

Please include the following information with all support requests:

�x         The version you are running. This information can be obtained from the About box. 
�x         The ‘ismsrv.log' file. This file is located in the installation directory. The default location is:

o    Windows Server 2003/XP – c:\documents and settings\all users\application data\CornerBowl\
Internet Server Monitor\ismsrv.log 

o    Windows Server 2008/7/Vista – c:\programdata\CornerBowl\ Internet Server Monitor\ismsrv.log 

�x         The operating system version. 
�x         If applicable, your license key. 
�x         Description of your problem. Please provide as much information as possible so we can reproduce the

problem if necessary. 

We’ll try to help you as fast as possible, typically the same or next day.

If you have any comments or suggestions for the next releases, please let us know.

For more information, s ee:

Contact Information
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