
About

Centralized Drive Monitoring and Directory Monitoring
SMART Disk Monitor is a network wide drive space monitor tool enabling System Administrators to centrally
monitor disk utilization, SMART predictive failure notifications, directory sizes, user access permissions, file
extension break down, and recently accessed files.

Features at a Glance
         Monitors disk utilization, SMART predictive disk failure notifications, and online status. 
         Sends fully customizable email alerts to system administrators. 
         Schedule executive summary reports that include disk utilization and SMART status for multiple

computers and disks. 
         Graphically displays multiple disks' utilization percentage. 
         Stores and graphically displays disk utilization over time. Historical data is stored in CSV format

optimized for Microsoft Excel. 
         Monitor directory sizes and send fully customizable email notifications to users and customers. 
         Create directory and file access permission reports simplifying Sarbanes Oxley auditing of mission

critical data access. 
         Generate file extension break down reports. 
         Identify recently or rarely accessed files using our recently accessed files reports. 
         Sub-directory size reports enable system administrators to quickly identify large or growing

sub-directories. 
         Automatically publish reports to your Intranet web server. 
         Group computers by logical groups. 
         Includes tray icon status. 
         Sends email notification when drive monitors fail. 
         Supports SMTP authentication. 
         No installation requirements on managed computers or devices. 

Architecture
SMART Disk Monitor consists of three major components:

User Interface: The user interface is used to configure the disks to monitor, configure the reports to
generate, and create on-demand reports.

Windows Service: The service monitors disks and generates scheduled reports using multi-threaded code
enabling hundreds of drives and reports to run relatively fast.  All non-user interface alerts are fired from the
service.  

Tray Icon: The tray icon is responsible for firing user interface dependent alerts (message box, sound,
system tray popup, etc.) including application status.  When the service polls disk drive usage the highest
alert level is reflected in the tray icon. When the alerts status is cleared, the tray icon changes its image
back to normal.
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User Interface Components
 

The SMART Disk Monitor user interface is made up of several views that enable you to configure disk for
monitoring, view selected item details, and view status messages.

Network
The Network View contains four (4) root tree nodes.

Network

Use the Network node to locate and configure monitoring for remote disks.

Local Disks

Use the Local Disks node to configure monitoring for the local disks.

Mapped Computers

Use the Mapped Computers node to add computers that are not visible from the Network node or to assign
specific logon credentials for a computer.

Monitored Disks

Once you configure a disk to be monitored, the disk displays under this node. Use this node to quickly
re-configure or display properties of configured disks.

Detail
The Detail view contains detailed information about the selected node in the Network view.

History
The History view displays the selected disk’s utilization history.  Utilization history is only available for
configured disks.

Directory Utilization
The Directory Utilization view displays the each sub-directory’s percentage utilization as a part of Network
view’s selected disk or directory.  To display the sub-directory utilization, select the disk or directory in the
Network view and the click Calculate Directory Size from the Tools menu item.

Output
This window displays application status messages.

Service Output
The windows service writes status messages to a log file in the program data directory. This window tails the
log file and displays each status message.  This file is located in the following directory:

         Window XP/2000: '\documents and settings\all users\application
data\CornerBowl\DiskMonitor\dm.log’

         Windows Vista: ‘\programdata\CornerBowl\DiskMonitor\dm.log’
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System Requirements
 

.Net Framework 2.0
The installation detects if .Net Framework 2.0 is already installed. If not, the framework is automatically
downloaded from Microsoft and then installed.

Domain administrator account credentials
To access admin shares from the user interface, your login must have domain administrator rights. When
scheduling the service to monitor a drive, the service must be run with domain administrator rights. The first
time the application is run, you will be prompted to assign domain administrator rights to the service.  For
more information see Security.

Microsoft Windows Management Instrumentation (WMI) Support
SMART Disk Monitor uses the Microsoft Windows Management Instrumentation (WMI) API to monitor
SMART predictive failure and to generate access permissions reports. WMI is preinstalled in Windows Server
2008, Vista, Windows Server 2003, Windows XP, and Windows 2000.

Windows NT Workstation 4.0 SP4 and later: WMI is available through "Add/Remove Windows
components" in Control Panel, as WBEM option install. A later, more comprehensive, version is available as
an Internet download from http://www.microsoft.com/downloads. See "WMI CORE 1.5 (Windows 95/98/NT
4.0)". 

If WMI is not an option, SMART status will not be available and you will not be able to run access permission
reports.

For information on troubleshooting WMI see Troubleshooting.
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Licensing
 

Corner Bowl Software offers 6 different licenses:

Desktop
This license allows you to install the software on a single workstation and monitor disks on 20 computers.
Please note, this license can not be installed on a Windows Server operating systems, however; the software
can still remotely manage Windows Server computers. 

Server
This license allows you to install the software on a single server or workstation and monitor disks on 50
computers. 

Unlimited
This license allows you to install the software on a single server or workstation and manage disks on an
unlimited number of computers. 

5 Pack
Includes 5 Unlimited licenses enabling your organization to load balance, install SMART Disk Monitor on
alternate networks or on various System Administrators' computers. 

Enterprise
Includes 20 Unlimited licenses and includes an additional year of support and updates for a total of 2 years of
support and updates. 

Single Server
This license allows you to install the software on a single server or workstation and manage local disks only. 

Support and Maintenance
Your purchase of Network Event Viewer includes:

         Email and phone support for 1 year. 
         Product updates for both maintenance builds and major releases for 1 year. 
         In addition, annual maintenance contracts can be purchased for 50% the original list price. 
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Registration
 

To register your software, visit http://www.cornerbowl.com and purchase a license. Once purchased, we will
automatically email you a license key. After you receive your license key, select Register from the Help
menu item. When prompted, specify the email address the license key was emailed to and the license key.
Click Submit. Our software will transmit the email address, license key, and the active IP address’s MAC
address to our registration web service running on our web server. Once verified a digitally signed license file
will be transmitted back to you. This file will automatically be saved to your program data directory. Licenses
can be transferred to another computer upon request.
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Update Service
 

All or our software supports automatic updates. At startup, each of our user interfaces downloads an XML file
from our web server. Using version information, our software determines if an update is necessary. License
information may be transmitted to our registration web service, also running on web server, to determine
upgrade eligibility. If eligible, our software will download the latest version from our web server. 

Each license comes with access to updates and major releases for 1 year. After that, you can purchase a
maintenance contract that provides you access to updates and major releases for 1 more year.
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About Corner Bowl Software
 

Who We Are
Corner Bowl Software is a privately held company located in Park City, Utah, USA. We have been developing
and selling software specifically for Information Technology professionals for over 7 years now. Our products
are designed, developed, and continually updated in direct response to user feedback. All of our software
tools are developed and supported in Park City. 

Our Software
Corner Bowl Software offers 4 distinct software tools that enable System Administrators to monitor and
maintain their servers and workstations. We offer event log, text log, and syslog management applications as
well as disk monitoring and server monitoring software tools. Our oldest and most popular applications are
our event log management and disk monitoring applications (Network Event Viewer and SMART Disk
Monitor). Both our text log and server monitoring tools (Text Log Monitor and Internet Server Monitor) are
relatively new and quickly gaining traction. We welcome you to evaluate our software tools and very much
appreciate feedback enabling us to update our applications to meet your demanding needs. 

Development Cycles
Corner Bowl Software prides itself on producing high quality usable software that utilizes the latest user
interface components. We receive feature requests on a daily basis and in response have implemented a
development system that enables us to quickly add, test, and release new features. Over the years, we have
worked closely with System Administrators during Sarbanes Oxley compliance audits providing them with
new features that enable them to more quickly respond to auditor requests. 

How to Contact Us

Our Address
Corner Bow l Softw are
PO Box 682876
Park City, Utah 84068, USA

Support Inquiries
Email: support@cornerbowl.com
Phone: 1-866-543-9470

Sales Inquiries
Email: sales@cornerbowl.com
Phone: 1-866-543-9470
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Monitoring Disks
 

Selecting disks
Disks can be selected via the Network View or the Configuration Wizard.  If you select the disks via the
Network View, the list of selected disks is displayed in the Disks tab of the Configuration Wizard.  If no disks
are selected when the Configuration Wizard is opened, you must first select the disks to configure from the
Disks tab of the Configuration Wizard.  

To open the configuration wizard
Select Configuration Wizard from the File menu item or select the toolbar button.

Please note when viewing and updating configurations for multiple disks the following rules apply:

         Text fields and combo-boxes that have different configuration values are empty.
         Check boxes that have different configuration values display with a square rather than empty or with a

check box.
         Setting a value in a control sets the value for all the selected disks.

Specifying a schedule
The Schedule tab enables you to schedule the frequency to poll disks and automatically clear alerts.

Check the Enabled check box to schedule automatic polling.

Use the Frequency group box to specify the schedule.

Note:  If you monitory every X minutes or once an hour, you have the option to exclude a single period during
each day.  For example, you can monitor a disk every 15 minutes excluding 11:00 PM – 2:00 AM.

To limit email spam, the service can be configured to automatically clear alerts.  At any time the next higher
level of alert is fired if appropriate, however; once a higher level alert is fired, lower or equal level alerts are not
fired until the duration you configure has exceeded.  Alerts levels are defined in the following order:

         Warning
         Critical
         SMART
         Error

To configure alerts to automatically clear
Check the Automatically clear alerts after check box and specify the duration to wait till alerts are cleared
enabling alerts to re-fire.  

Use the Configuration combo box to fine tune parameters for each disk selected.

Configuring warning and critical alerts
Alerts can be disabled by de-selecting Enable warning/critical alerts.

Warning thresholds must be higher than critical thresholds.  

If you enable these alerts, but do not assign an action, notification is limited to the tray icon.  

Configuring SMART alerts
SMART alerts enable System Administrators to receive notification before a disk fails.  When a disk is about
to fail, it may provide warning.  To receive notification of this warning you must enable SMART alerts.

If you enable this alert, but do not assign an action, notification is limited to the tray icon.  

Configuring error alerts
Error alerts enable System Administrators to receive notification when a computer or disk is down or
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un-reachable.  If the service is unable to poll a disk, an error alert can be fired.  

If you enable this alert, but do not assign an action, notification is limited to the tray icon.

Configuring history reporting
By default, disk utilization information is saved to a CSV (comma separated) file.  The CSV file includes the
time, space used, and free space.  The CSV format has been optimized for use with Microsoft Excel.  Use
the History tab to either disable history reporting, provide an alternate filename or location, and set the
maximum number of days to retain.  The CSV file is used by SMART Disk Monitor to display the disk
utilization history.  If you choose to disable history reporting, you will not be able to see the historical charts.

Data retention

Over time the history file may become quite large ultimately slowing down the user interface.  Use this tab to
configure the maximum number of days to retain.  The software will automatically truncate the history file
when ever the service updates the historical chart or you view the historical chart within the user interface.

Configuring directories to monitor
Although the Directory Monitor tab can be used to add new directories to monitor, this tab is ideal for
displaying all directories configured for the disk as well as removing currently monitored directories.  To
monitor a directory’s size or access permissions, click the Add button.  To modify a configuration, select
directory and click the Properties button.  To remove a configuration, select the directory and click the
Remove button.  For more information see Monitoring Directories.

Creating and using templates
Templates enable you to easily configure disks with pre-set values.  Schedule and alert configuration
parameters are saved to the template.  The history and directory monitor parameters are not included in the
template.  Once you have setup email addresses, messages, and thresholds click Save As Template. 
Specify the template name and click OK.  To load the template into a new configuration, click Load Template,
select the template, and lastly click OK.

Verifying configurations 
The Verify dialog enables you to review the configuration being set for each disk.
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Monitoring Directories
 

SMART Disk Monitor enables System Administrators to monitor the size of particular directories, fire warning
and critical alerts, generate email, CSV and XML directory utilization reports, and generate access
permissions reports.

How to monitor a directory
From the Monitored Disks tree node within the Network View, expand to the directory of interest,  right click,
and select Directory Monitor Wizard.

How to exclude sub-directories
From the Directory tab, add and directories to exclude from the recursion.  

During runtime, ‘.\’ is replaced with the UNC path being monitored.  For example, if you want to exclude the
Program Files directory, specify:

c:\program files 

or

.\program files.

During runtime, ‘..’ is replaced with any directory at the level.  For example, if you want to exclude the ‘
Temporary Internet Files’ directory for all users on the target system you would use the following format: 

C:\Documents and Settings\..\Local Settings\Temporary Internet Files

or

.\Documents and Settings\..\Local Settings\Temporary Internet Files

Specifying the schedule
The Schedule tab enables you to schedule the frequency to recurse the disk or directory.

Check the Enabled check box to schedule automatic polling.

Use the Frequency group box to specify the schedule.

Note:  If you monitory every X minutes or once an hour, you have the option to exclude a single period during
each day.  For example, you can monitor a directory once an hour excluding 11:00 PM – 2:00 AM.

Configuring directory size reports
Directory size reports can be emailed and saved to HTML, CSV, TXT, or XML.  Directory size reports include
the computer name, disk drive, path, directory names, sizes, file counts, and sub-directory counts.  When
saved to file, previous reports can be backed up to a sub-directory called backup, appended to (TXT and XML
only), or overwritten.

Email and HTML templates

Directory size reports utilize HTML templates when emailed and saved to file.  HTML templates enable users
to define their own content and look and feel.  For more information see Email and HTML Templates.

Configuring history reporting
Directory size information is saved to a CSV (comma separated) file.  The CSV file includes the time, root
directory size, total directory and sub-directory file count, and total sub-directory count.  The CSV format has
been optimized for use with Microsoft Excel.  The CSV file is used by SMART Disk Monitor to display the
directory size history.

Over time the history file may become quite large ultimately slowing down the user interface.  Use the Size
Reports tab to configure the maximum number of days to retain.  The software will automatically truncate the
history file when ever you view the historical chart within the user interface. 

Page 10



To view the historical chart right click on the directory and select Properties.

Configuring access permissions reports
Access permission reports contain user rights assigned to the directory, sub-directory, and/or files.  Access
permission reports were developed for customers that needed print outs of users with any type of access to a
particular directory.  Very specifically, the reports were needed for Sarbanes Oxley auditors.  Access
permissions reports can be emailed and exported to XML or CSV. 

To exclude sub-directories and files from the report, de-select the appropriate check boxes.

To concatenate all sub-directory and file rights into one line item in the report, de-select Detail sub-directories
and files.

To hide the detailed column information about the particular Ace types, Ace flags, and rights, de-select the
appropriate check boxes.

To limit the report to a particular set of rights, de-select the rights you are not interested in.

For information on on-demand access permission reports see, Access Permissions Reports.

HTML templates

Access permissions reports utilize HTML templates when emailed.  HTML templates enable users to define
their own content and look and feel.  For more information see Email and HTML Templates.

Configuring warning and critical alerts
SMART Disk Monitor enabled users to set thresholds based on both a maximum size and a change in size.

Monitoring the maximum size
Check either Enable warning alerts or Enable critical alerts depending on the threshold level.

Specify the maximum allowed size in either GB, MB, KB, or bytes.

Monitoring a change in a directory’s size
You may find it advantageous to receive notification when a directory size significantly increases or
decreases between checks.  For example, if a directory increases by 5 GBs since the previous check,
SMART Disk Monitor can fire an alert notifying you of this increase.

Automatically clearing alerts
Unlike the disk monitoring, directory size alerts can independently clear the warning and critical alerts. 
Independent alert clearing was developed so customers, ISPs specifically, could fire critical alerts at a high
frequency while firing warning alerts at a lower frequency.  While developing this functionality, we added the
ability to select user defined email templates.  The templates are HTML based and include tags that SMART
Disk Monitor parses and replaces with the appropriate values.  A different template may be assigned to each
directory if necessary enabling, for example, a customer’s name to be present.  Please refer to the default
template for a sample.  All available tags are included in the file and are wrapped with {}.  The default HTML
template is located in the following location:

C:\Program Files\DiskMonitor\HtmlTemplates\directory_alert.html

For more information see Email and HTML Templates.

Configuring error alerts
Error alerts enable System Administrators to receive notification when a computer or disk is down or
un-reachable.  If the service is unable to recurse the directory, an error alert can be fired.  

If you enable this alert, but do not assign an action, notification is limited to the tray icon.

Monitoring a directory for changes
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SMART Disk Monitor enables system administrators to receive notification when files are created, modified,
deleted, or rename within a specific directory or sub-directory.  Use the File Monitor tab to enable real-time
monitoring of directory changes.  Use the mask list boxes to create new masks to include or exclude in your
results.  For example, specify *.txt to receive notification for all text file.  Changes can be logged to a file or
emailed.  Please note you will receive one email for each change event fired by the operating system.

Creating and using templates
Templates enable you to easily configure directory reports with pre-set values.  All parameters in including
directory exclusions are saved to the templates.  Once you have setup all aspects of the report that you want
to include in the template, click Save As Template.  Specify the template name and click OK.  To load the
template into a new configuration, click Load Template, select the template, and lastly click OK.

Verifying configurations 
The Verify dialog enables you to review the configuration being set for each directory.
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Clearing Alerts
 

You can specify a warning threshold and a critical threshold. When a threshold is crossed, the assigned
actions are fired. When ever a critical threshold is crossed, only the critical threshold actions are fired, even if
the warning threshold action was never sent. Only one notification is fired per threshold until you clear the
alert state. This format prevents unintentional notification spamming.

If you want the assigned actions to be automatically re-fired when a disk remains beyond its configured
threshold, you can specify the frequency to automatically clear the alerts. On the Schedule tab of the
Configuration Wizard dialog, Check the Automatically clear alerts after check box and specify the frequency
to clear warning or critical alerts.

The user interface denotes a disk in an alert state with either a yellow or red icon over the disk icon. SMART
Disk Monitor supports 4 states, warning, critical, S.M.A.R.T., and error. To clear the alert state, select the
disk, and click Clear Alerts from the Edit menu. Once the alert state is cleared, notifications will resume.
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Tray Icon
 

Icons in the lower right corner of Windows Taskbar are called Tray Icons. Tray Icons display application
status. The Internet Server Monitor tray icon has three states:

 Service Running
This is the normal state and indicates all monitors are operational.

 Service Stopped
This state indicates the DiskMonitor service is not running. Either use the Windows Service Control Manager
or SMART Disk Monitor to turn the DiskMonitor service on. Once running, the icon will change to the Service
Running state.

 Warning Threshold Crossed
At least one disk and/or directory have crossed a warning threshold.

 Critical Threshold Crossed
At least one disk and/or directory have crossed a critical threshold.

 SMART status degraded
At least one disk has returned a degraded SMART status.

 General Monitor Error
At least one scheduled disk and/or directory monitor failed to execute.

To turn the tray icon off
Select Close Tray Icon from the Service menu.

To turn the tray icon on
Select Start Tray Icon from the Service menu.

 

Note:  If you close the tray icon, the tray icon application will exit and you will no longer be able to receive
user interface alerts.  These alert types include, message box alerts, sound alerts, and tray icon popups.
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Summary Reports
 

SMART Disk Monitor can be configured to generate summary reports that can be automatically emailed per a
user defined schedule.  By default, summary reports include the computer name, disk drive, status, capacity,
free size and percent, used size and percent, and S.M.A.R.T. status. 

HTML templates
Two HTML templates have been provided that enable you to receive tabular summary or detailed summary
including utilization pie charts and disk history charts.  The file names are ‘report.html’ and ‘
report_with_charts.html’. The default templates are stored under the installation directory in a sub-directory
called HtmlTemplates.  The templates are HTML files that must contain <ODD> and <EVEN> tags.  Each file
contains replacement tags denoted with {}.  Please review the supplied templates for your reference.  For
more information see Email and HTML Templates

How to create a new report
Select Summary Reports from the Tools menu item.

Select the New button to open the Summary Report Wizard.

Provide a name for the report.

Specify all email addresses to include.

Modify the subject to your liking.

Specify the HTML template to apply.  Click Next

Check the logical group or disks to include in the report.  Click Next.

Specify the frequency to run and email the report.

When you are finished, click Finished.

How to modify a report
Select Summary Reports from the Tools menu item.

Select the report of interest and click Properties.

Make the necessary changes within the Summary Report Wizard.

How to remove a report
Select Summary Reports from the Tools menu item.

Select the report of interest and click Delete.
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Directory Summary Reports
 

SMART Disk Monitor can be configured to generate directory summary reports that can be automatically
emailed per a user defined schedule.  Directory summary reports include detailed information about each
configured directory monitor.  This function was specifically added so System Administrators could easily
display directory and sub-directory size information from multiple servers within a single email report.  For
example, a directory summary report can list detailed information about the Windows folder on each domain
controller.

HTML templates
An HTML template has been provided to enable you to receive tabular summary.  The file name is ‘
directory_report.html’ and is stored under the installation directory in a sub-directory called HtmlTemplates. 
The template is an HTML file that must contain a <DIRECTORY> tag that wraps <ODD> and <EVEN> tags. 
Each file contains replacement tags denoted with {}.  Please review the supplied templates for your
reference.  For more information see Email and HTML Templates.

How to create a new report
Select Directory Summary Reports from the Tools menu item.

Select the New button to open the Directory Summary Report Wizard.

Provide a name for the report.

Specify all email addresses to include.

Modify the subject to your liking.  

Specify the HTML template.  Click Next.

Check the logical group, disks, or monitored directories to include in the report.  Click Next.

Specify the frequency to run and email the report.

When you are finished, click Finished.

How to modify a report
Select Directory Summary Reports from the Tools menu item.

Select the report of interest and click Properties.

Make the necessary changes within the Directory Summary Report Wizard.

How to remove a report
Select Directory Summary Reports from the Tools menu item.

Select the report of interest and click Delete.
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Access Permissions Reports
 

Access permission reports list user rights assigned to the directory, sub-directory, and files.  Access
permission reports were developed for customers that needed print outs of users with any type of access to a
particular directory.  Very specifically, the reports were needed for Sarbanes Oxley auditors.  Access
permissions reports can be emailed and exported to XML or CSV. 

To create an on-demand report
From the Network  view, select the disk or directory of interest.  Right click and select, Generate Access
Permissions Report.

To exclude sub-directories and files from the report, de-select the appropriate check boxes.

To concatenate all sub-directory and file rights into one line item in the report, de-select Detail sub-directories
and files.

To hide the detailed column information about the particular Ace types, Ace flags, and rights, de-select the
appropriate check boxes.

To limit the report to a particular set of rights, de-select the rights you are not interested in.

Filtering the report
Once the report is complete, use the Directory combo box (if include sub-directories was selected) and the
Users combo box to filter the report view.

Printing the report
Once you have generated the report and filtered it to your liking, you can print the report.  Select Page Setup
to select the page orientation and margins.  Once dismissed, select the Print button.

Exporting the report to XML or CSV
Once you have generated the report and filtered it to your liking, you can export the report to an XML or CSV
file.  Select the Export button and specify the filename.

Scheduling reports
For more information on scheduling access permissions reports, see Monitoring Directories.
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File Extension Reports
 

System Administrators have the option of generating file extension reports on demand.  File extension reports
recurse a selected disk or directory and calculate the count and total size for each file type.  The output is a
Windows Explorer style form.  When selecting a directory within the report, the detail view contains a list of
all extensions found within the selected directory and within each sub-directory.  Navigate through the tree to
find the actual location within a directory that contains the files.

To generate a file extension report
From the Network View, right click a disk or directory to recurse and select Calculate Directory Size and
Extension Detail.

To print the report results
Once a report is complete you have the option to print the report directory to your printer.  Use the Page
Setup button to specify your printer and page orientation.  

Click the Print button to print the report.

To export the report results
Once a report is complete you have the option to export the report to CSV or XML.  The CSV export is
optimized for Microsoft Excel.

Click the Export button and specify the path, filename, and file type. 

 

Note:  When printing or exporting the report, the contents are limited to the currently selected directory.
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Last Accessed Files Reports
 

The last accessed files report function enables System Administrators to recurse a directory structure and
view a list of the last access files as well as a list of files not accessed since a specified date.

To run a last access files report
From the Network View, right click a disk or directory to recurse and select Last Access Files Report.

Select the Show the last X access files option.

Specify the number of files to include in the report.

Click Run Report.

To run a report that lists files not accessed since a specified date
From the Network View, right click a disk or directory to recurse and select Last Access Files Report.

Select the Show all files that have not been accessed since X option.

Specify the date.

Click Run Report.

To print the report results
Once a report is complete you have the option to print the report directory to your printer.  Use the Page
Setup button to specify your printer and page orientation.  

Click the Print button to print the report.

To export the report results
Once a report is complete you have the option to export the report to CSV or XML.  The CSV export is
optimized for Microsoft Excel.

Click the Export button and specify the path, filename, and file type. 
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Actions
 

Actions provide notification when a disk is running low on space, a degraded SMART status is detected, a
directory expands quickly, a directory reaches a specific size, or a monitor fails to execute.

Monitor Types
When assigning actions to monitors you will only be prompted with actions that match the monitor type.  4
types are available, Disk Space, Directory Size, SMART Status, and Error.  For example, when configuring a
disk space monitor critical threshold you will only see Disk Space actions within the available actions list
box.

Replacement Tags
Many of the available actions support inserting replacement tags.  Replacement tags enable users to see
specifics about the disk or directory within their action.  For example, when creating a Message Box action,
users can insert disk size and utilization tags that will be replaced with the disk specific information when
fired.  For more information see Replacement Tags.

Email and HTML output Actions
Both email and HTML output actions use HTML templates to generate the content.  Users can create their
own HTML templates enabling them to fully customize not only the content displayed but the look and feel as
well.  For more information see Email and HTML Templates.

To create a new action
Select Configure Actions from the File menu.

Specify a name.

Select the type of action, for example Email, Message Box, or Syslog.

Select the monitor type.

To assign an action to a disk monitor
From the Network View, select the disk, right click and select Configure Selected Computers.

Select the appropriate tab and assign your actions.

To assign an action to a directory monitor
From the Network View, select the directory, right click and select Directory Monitor Wizard.

Select the appropriate tab and assign your actions.

 

For more information, see:

Monitoring Disks

Monitoring Directories

Email and HTML Templates

Replacement Tags
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Calculating Directory Sizes
 

One of the key features of SMART Disk Monitor is the ability to recurse a disk's directory structure. This
recursion enables you to view usage across all multiple directories. You can then sort the detailed view by
size, export the data to XML or CSV, or print a report. 

For more information on exporting the detailed view, see Saving the Detailed View to File.

For more information on printing the detailed view, see Printing.

Recursing a disk or directory
Select the disk or directory of interest and click Calculate Directory Size from the Tools menu item. The
recursion will begin. Please note that this recursion may take several minutes or even longer depending on
the size of the target disk or directory.

Graphically viewing directory utilization
Once you have calculated the directory size, you can graphically view the utilization relative to the parent
directory or disk.  To view the utilization graphic, select Windows | Directory Utilization from the View menu
item.

Monitoring directory sizes
For more information on automatically monitoring directory sizes see, Monitoring Directories.
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Copying Detail View Items to the Clipboard
 

To copy a line in the detailed view to the clipboard, select the line and press Ctrl-C, or Copy from the Edit
menu, or select the toolbar button.

The entry contents are copied to the system clipboard in string format. Once in the system clipboard, you
can paste the contents to an email message or ASCII editor by pressing Ctrl-V or selecting Paste from the
target application's Edit menu. 
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Directory Size History
 

By default, directory size information is saved to a CSV (comma separated) file.  The CSV file includes the
time, root directory size, total directory and sub-directory file count, and total sub-directory count.  The CSV
format has been optimized for use with Microsoft Excel.  Use the Directory Size tab in the Directory
Configuration Wizard to set the maximum number of days to retain.  The CSV file is used by SMART Disk
Monitor to display the directory size history.

Viewing directory size history
The history can be viewed in two ways:

         Select Windows | History from the View menu.  From the Network  or Detailed view, select the
monitored directory.

         From the Network  or Detailed view, right click on the monitored directory and select Properties.

Emailing the history through Microsoft Outlook
The history can be emailed using Microsoft Outlook.  To email the history, select the monitored directory
from the Network  or Detailed view.  Right click and select Properties.  Select Email History.  The image is
exported to a JPG and the chart data is exported to CSV.  The files are then added as email attachments.
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Disk Utilization History
 

By default, disk utilization information is saved to a CSV (comma separated) file.  The CSV file includes the
time, space used, and free space.  The CSV format has been optimized for use with Microsoft Excel.  Use
the History tab in the Configuration Wizard to disable history reporting, provide alternate file names and file
locations, and set the maximum number of days to retain.  The CSV file is used by SMART Disk Monitor to
display the disk utilization history.  If you choose to disable history reporting, you will not see the historical
charts.

Viewing disk utilization history
The history can be viewed in several ways:

         Select Windows | History from the View menu.  From the Network  or Detailed view, select the
monitored disk.

         From the Network  or Detailed view, right click on the monitored disk and select Disk History.
         Open your Internet browser and open the index.html file located in your HTML output directory.  For

more information, see Web Server.

Emailing the history through Microsoft Outlook
The history can be emailed using Microsoft Outlook.  To email the history, select the monitored disk from
the Network  or Detailed view.  Right click and select Disk History.  Select Email History.  The image is
exported to a JPG and the chart data is exported to CSV.  The files are then added as email attachments.
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Email and HTML Templates
 

Email and HTML templates provide System Administrators the flexibility of creating custom alerts and
reports.  Not only can custom look and feel be implemented but content can be customized as well.  The
templates use custom section tags and content tags to define sections and content to include.  The best
way to customize your alerts and reports is to copy the template for the associated function and make your
change within the copied file.  Once you have completed your changes, apply the template to the alert or
report via the appropriate configuration dialog.

The following table lists the available HTML templates and their intended use.

HTML Template Description

access_permissions.html Used by the directory monitor when emailing access permission reports.

directory_alert.html Used by the directory monitor when emailing directory size alerts.

directory_report.html Used when emailing directory summary reports.

directory_size.html Used by the directory monitor when emailing directory size reports.

disk.html Used by the disk monitor when updating the HTML output for use by web
servers.  Configured via the Options dialog.

disk_alert.html Used by the disk monitor when emailing disk space alerts.

error_alert.html Used by both the disk and directory monitors when a failure occurs during
the polling process.

report.html Used when updating the HTML output and emailing disk summary
reports. 

report_with_charts.html Used when updating the HTML output and emailing disk summary
reports.  Includes a disk utilization pie chart and disk history chart for
each disk.  Please note this template is not assigned by default but is
provided as an option for users to apply.

smart_status_alert.html Used by the disk monitor when emailing SMART status alerts.

 

The following references list the tags supported by each function.  For more information see Replacement
Tags

Disk Space Alerts and HTML Output
Required sections:

NONE

The following tags are supported:
ALERT_STATE

ALERT_STATE_IMG

DATE

DISK

DISK_HISTORY_IMG

DISK_UTILIZATION_IMG

ERROR

FILE_SYSTEM

FREE

HOST

LOCALHOST

PATH

PERCENT_FREE

PERCENT_USED

PREVIOUS_SIZE

SCHEDULE

SMART_STATUS

THRESHOLD
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TIME

TOTAL

USED

 

SMART Status Alerts
Required sections:

NONE

The following tags are supported with each section of the HTML template:

All disk space alert tags are supported.

 

Directory Size Alerts
Required sections:

NONE

The following tags are supported:
ALERT_STATE

ALERT_STATE_IMG

DATE

DISK

FREE

HOST

LOCALHOST

PATH

PATH_SIZE

PERCENT_FREE

PERCENT_USED

PREVIOUS_SIZE

SCHEDULE

SMART_STATUS

THRESHOLD

TIME

TOTAL

USED

 

Directory Size Reports
Required sections:
<ODD>

</ODD>

<EVEN>

</EVEN>

 
The following tags are supported:

Header
All directory size tags are supported.

Even and Odd Rows
DIRECTORY

PATH_SIZE

FILE_COUNT

DIRECTORY_COUNT
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Access Permissions Reports
Required sections:
<ODD>

</ODD>

<EVEN>

</EVEN>

 
The following tags are supported:

Header
All directory size tags are supported.

Even and Odd Rows
DIRECTORY

USER

ACE_FLAGS

ACE_TYPE

RIGHTS

 

Disk Summary Reports
Required sections:
<ODD>

</ODD>

<EVEN>

</EVEN>

 
The following tags are supported:

Header and Footer
REPORT

SCHEDULE

DATE

TIME

LOCALHOST

Even and Odd Rows
ALERT_STATE

ALERT_STATE_IMG

DATE

DISK

DISK_HISTORY_IMG

DISK_UTILIZATION_IMG

ERROR

FILE_SYSTEM

FREE

HOST

PATH

PERCENT_FREE

PERCENT_USED

PREVIOUS_SIZE

SCHEDULE

SMART_STATUS

THRESHOLD

TIME

TOTAL

USED
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Directory Summary Reports
Required sections:
<DIRECTORY>

<ODD>

</ODD>

<EVEN>

</EVEN>

</DIRECTORY>

 
The following tags are supported:

Header and Footer
REPORT

SCHEDULE

DATE

TIME   

LOCALHOST

Directory Sub-Section Header and Footer
ALERT_STATE

ALERT_STATE_IMG

HOST

PATH

PATH_SIZE

PREVIOUS_SIZE

ERROR

Directory Even and Odd Rows
DIRECTORY

PATH_SIZE

FILE_COUNT

DIRECTORY_COUNT

 

Error Alerts
Required sections:

NONE

The following tags are supported:
ALERT_STATE

ALERT_STATE_IMG

DATE

DISK

ERROR

HOST

LOCALHOST

PATH

TIME

 

For more information, see:

Replacement Tags
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Logical Groups
 

Logical groups enable you to group disk configurations together.  For example, you may want to group all
your servers together.  

To create a logical group
Select New Logical Group from the File menu.

Specify the name and click OK.

To add disks to a logical group
From the Network View, drag and drop the disk from current group to the new group.  By default all
configurations are added to the (Unassigned Logical Group). 

To move multiple disk monitors to another logical group 
Select the source logical group.  From the detail view highlight the disk monitors to move.  Drag and drop the
monitors to the target logical group.
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Mapping Computers
 

The most common reason users map computers is to provide login credentials, however; computers online
but undiscoverable can also be specified.

To map a computer
Select Map Computer from the File menu or select the toolbar button.

From the map computer dialog, specify the hostname or IP address of the machine, the username,
password, and domain or workgroup.

To modify login credentials
From the Network view, select the computer under the Mapped Computers tree node.

Select Properties from the File menu item or click the properties toolbar button.

Update the username and password as necessary.
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To remove a mapping

If you are no longer monitoring a computer that was previously mapped, or you no longer need to specify login
credentials, you can remove the mapping. From the Network view, select the computer under the Mapped
Computers tree node. Press the Delete key, select Delete from the Edit menu, or click the delete toolbar
button.

 

For more information, see:

Security
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Network View
 

The Network View contains four (4) root tree nodes.

Network

Use the Network node to locate and configure monitoring for remote disks.

Local Disks

Use the Local Disks node to configure monitoring for the local disks.

Mapped Computers

Use the Mapped Computers node to add computers that are not visible from the Network node or to assign
specific logon credentials for a computer.

Monitored Disks

Once you configure a disk to be monitored, the disk displays under this node. Use this node to quickly
re-configure or display properties of configured disks.

Navigation
SMART Disk Monitor enables you to navigate your network just as if you where in Windows Explorer. The big
difference is, however; once you click on a computer all available shares are displayed. Hidden root shares
display a disk icon while directory based shares display a folder icon. 

If you receive an access denied error after selecting a computer, you can manually map a computer and
specify login credentials. For more information see Mapping Computers.

When navigating your network, computers online but undiscoverable can be manually added. For more
information see Mapping Computers.
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Printing
 

SMART Disk Monitor enables you to print the current detailed view.  This is useful when you want a print out
of all disk utilization information for a specific logical group or after you have re-cursed a disk (calculated the
directory size) or directory and want a print out of the directory utilization.

To print the current view
Select Page Setup from the File menu.  Use the Page Setup dialog to select the page orientation and
margins.  Once you have dismissed the Page Setup dialog, press Ctrl-P, or select Print from the File, or
select the toolbar button. 
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Replacement Tags
 

Replacement tags are used for actions such as message box alerts, email alerts, email reports, and HTML
output for use by your web server.  From the Actions Manager you have the ability to select from a list of
available tags.  Depending on the type of action, disk, directory, SMART, or error, you are prompted with
different tags.  Tags for use within actions are wrapped with <> signs.  For more information see Actions.

Replacement tags are also used within HTML templates.  Tags for use within HTML templates are wrapped
with {} signs.  For more information see Email and HTML Templates.

The following table lists available tags and a corresponding description:

Tags Description
ACE_FLAGS Used by access permission reports to display ACE FLAGS

associated with a directory, file and user.  For use with email and
HTML output only.

ACE_TYPE Used by access permission reports to display ACE TYPES
associated with a directory, file and user.  For use with email and
HTML output only.

ALERT_STATE Replaced with the disk or directory's current alert state.  (CRITICAL,
WARNING, ERROR, SMART).

ALERT_STATE_IMG Replaced with the image filename associated with the alert.  For use
with email and HTML output only.

DATE Replaced with a short date string.
DIRECTORY Replaced with a directory name used by directory summary reports,

directory size reports, and access permission reports.  For use with
email and HTML output only.

DIRECTORY_COUNT Replaced with the total sub-directory count.  Used by directory
summary reports and directory size reports.  For use with email and
HTML output only.

DISK Replaced with the monitored disk name.

DISK_HISTORY_IMG
Replaced with the filename the disk history chart is contained.  For
use with email and HTML output only.

DISK_UTILIZATION_IMG
Replaced with the filename the disk utilization chart is contained.  For
use with email and HTML output only.

ERROR Replaced with the error generated when a monitor fails.
FILE_COUNT Replaced with the total file count.  Used by directory summary reports

and directory size reports.  For use with email and HTML output only.
FILE_SYSTEM Replaced with the file system.  For example NTFS.
FREE Replaced with the free space.  For example 150.24 MB.
HOST Replaced with the monitored hostname.
LOCALHOST Replaced with the hostname of the machine the software is installed. 

Typically used to identify the machine alerts are fired from.
PATH Replaced with the UNC path for the disk or directory depending on the

monitor type.
PATH_SIZE Replaced with a directory’s size.  Used by directory monitors only.
PERCENT_FREE Replaced with the percent free.  For example 13%.
PERCENT_USED Replaced with the percent used.  For example 87%.
PREVIOUS_SIZE Replaced with a directory’s previous size.  Typically used when an

alert is fired in response to a massive change in a directory's size
since the previous poll.  Used by directory monitors only.

RIGHTS Used by access permission reports to display user rights associated
with a directory or file.  For use with email and HTML output only.

SCHEDULE Replaced with a description of the monitor's schedule.
SMART_STATUS Replaced with current SMART status.  For example, OK or Degraded.
THRESHOLD Replaced with a description of the monitor's threshold that caused the

alert to fire.
TIME Replaced with a short time string.
TOTAL Replaced with the disk's capacity.  For example 80 GB.
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USED Replaced with the used space.  For example 25.67 GB.
USER Used by access permission reports to display the user name

associated with a set of rights.  For use with email and HTML output
only.

 

For more information, see:

Actions

Email and HTML Templates
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Saving the Detailed View to File
 

At any time you can export the current detailed view contents to a CSV or XML file. Select Save Current View
As from the File menu. Specify the file name and type. CSV, or XML are supported. The CSV export is
optimized for Microsoft Excel. Lastly, click Save.
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Automatically Configuring New Computers
 

SMART Disk Monitor enables you to configure the service to monitor Active Directory organizational units for
new computers.  When new computers are added, a pre-configured configuration template you create is
assigned and automatic monitoring commences.

Step 1: Create a disk monitor configuration template.

Step 2: Select an Active Directory Entry.

Step 3: Assign a template to the directory entry, add computer exclusions, specify a schedule, and
optionally configure an email report to be generated upon completion.

Creating a disk monitor configuration template
The first step is to save a current disk monitor configuration to a template.  From the Network  view, right click
a disk and select Configure Selected Disks.

Select the Schedule tab.

From the Configuration combo box at the top, select a single disk if not already selected.

Click Save As Template.

Specify a name and click OK.

Close the Configuration Wizard.

Selecting an Active Directory Entry
Select Automatically Configure New Computers from the File menu item.

The Active Directory Entry selection dialog will open automatically connecting to the domain’s Active
Directory tree.  If you are off domain click the Add button to manually configure your Active Directory
connection.  For more information see Configuring Active Directory.

Navigate to the organizational unit of interest and select Configure Selected Entry.  The Active Directory Auto
Configurator will now load.

Configuring the Active Directory Auto Configurator
Select the Active Directory Entry to configure from the list.

Check the Enable check box to enable the path to be polled.

Select a template to apply to discovered computers and then click Next.

Add computers you do not want to monitor and then click Next.

Specify a schedule.

Optionally specify an email address to send a report to.

 

For more information, see:

Configuring Active Directory
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Configuring Active Directory
 

SMART Disk Monitor enables you to configure the service to monitor Active Directory organizational units for
new computers.  When new computers are added, a pre-configured configuration template you create is
assigned and automatic monitoring commences.

When configuring the Active Directory Auto Configurator SMART Disk Monitor automatically connects to your
domain’s Active Directory tree.  If you are off domain or you want to connect to an alternate Active Directory
tree you can manually configure multiple Active Directory trees.

To configure alternate trees or credentials
Select Options from the Tools menu.  At the bottom of the dialog, click the Configure Active Directory
button.  Specify the appropriate Active Directory or LDAP connection string and credentials.

Please note when specifying alternate credentials the service will use these credentials to map and connect
to each discovered computer.

 

For more information, see:

Automatically Configuring New Computers
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Options
 

Use the options dialog to set configuration parameters.

To open the Options dialog, select Options from the Tools menu item.

The options dialog contains the following pages:

Mail Connection

Web Server

Syslog
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Mail Connection
 

Mail Connection parameters are set via the Options dialog. To open the Options dialog, select Options from
the Tools menu item. Once open, select the Mail Connection tab.

Server Information
Specify the name of the SMTP server. For example: mail.yourserver.com.  If your server runs on a port other
than 25, for example 2000, use the following format:  mail.yourserver.com:2000

Logon Information
If your SMTP server requires authentication to send messages, specify your username and password.

Mail From Information
Optionally, specify the name and from address to appear in outgoing mail.

Testing Account Settings
When ever you change the mail server settings, it is a good idea to test the settings. To test the account
settings, specify a test email address then click the Send Test Email button.
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Syslog
 

SMART Disk Monitor uses Syslog in 2 ways.  First, you can configure a monitor to forward alerts to a syslog
server.  Second, the DiskMonitor Windows Service optionally logs status messages to a syslog server.

Use the Actions Manager to create an action that forwards alerts to your syslog server.

Use the Options dialog to configure the DiskMonitor Windows Service to enable or disable syslog messaging
as well as assign the host and facility to log to. 

 

Configuring the DiskMonitor Windows Service to Syslog

Select Options from the Tools menu item.

Enabled

Check to forward service messages to your syslog server.  

Host

Specify the host name of your syslog server. For example: yoursyslogserver.

Facility

Specify the syslog facility. The default value is Local1.

Note: If you change any settings, you must restart the service for the changes to take effect.

 

For more information, see:

Actions

RFC 3164 available at http://www.faqs.org/rfcs/rfc3164.html

 

Page 41

http://www.faqs.org/rfcs/rfc3164.html
http://www.faqs.org/rfcs/rfc3164.html


Web Server
 

SMART Disk Monitor automatically creates HTML pages that contain an index of all monitored disks.  When
the disk is selected in your browser, the utilization, status, and history is displayed.

Use the Web Server tab on the Options dialog to enable/disable automatic HTML document generation,
specify an alternate HTML template, override the output directory, and enable/disable HTML email when
emailing disk and directory summary reports.

To configure web server options
Select Options from the Tools menu item.  Select the Web Server tab.

HTML template
The HTML template enables users to create and apply their own HTML when exporting to their web server. 
Users can specify not only the content displayed using tags but the look and feel as well.  For more
information see Email and HTML Templates.

To change the location to output the HTML files
Specify the location to output the HTML files.

Disk and directory summary reports
SMART Disk Monitor uses both HTML and text when sending emails for disk and directory summary reports,
directory size reports, and access permissions reports enabling non-html email clients to display the reports.
If you only want to see reports using text, turn off the HTML email option.

Note: This option is unrelated to disk and directory monitoring alerts.  For more information see Actions.

 

Page 42



Change Service Login
 

SMART Disk Monitor uses a service to execute scheduled functionality. This service is called Disk Monitor.
In order for the Disk Monitor service to access network resources, it must run with domain administrator
rights. 

To change the service login credentials
Select Change Service Login from the Service menu item.

Specify a domain administrator username and password. Lastly, specify the domain. When you are finished,
click the Next button. The service configuration will be modified with these rights and the service restarted.

 

For more information, see:

Security
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Starting and Stopping the Windows Service
 

SMART Disk Monitor uses a Windows Service to monitor disks and generate reports.  To aid in
troubleshooting, the service can be started in verbose (debug) mode. In this mode, extra messages are
logged. 

To Start the Service
Select Start from the Service menu item.

If you are unable to start the service because of a login failure, you must reset the login credentials. For more
information see Change Service Login.

To Start the Service in Verbose Mode
Select Start (Verbose) from the Service menu item.

To Stop the Service
Select Stop from the Service menu item.

 

For more information, see:

Change Service Login

Windows Service Log File
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Windows Service Log File
 

The Disk Monitor Service logs all significant activity to a log file called 'dm.log'. This information is invaluable
when trouble shooting the service. This file is located in the installation directory. The default location is:

         Window XP/2000: '\documents and settings\all users\application data\CornerBowl\DiskMonitor
\dm.log’

         Windows Vista: ‘\programdata\CornerBowl\DiskMonitor\dm.log’

To View the Log File
Select View Log from the Service menu or select the toolbar button.

The entries are sorted from oldest to latest. The log file can also be viewed in any text editor. 

To Clear the Log File
The service automatically truncates the log file to a little less than 1 MB every hour on the hour. The service
will log an error when attempting to truncate the log file when the user interface is open. To manually clear or
delete the entire log file, the service must be stopped and the user interface closed. Once the service is
stopped and the user interface is closed, manually delete the log file. After the file has been deleted, re-start
the service. For more information on starting and stopping the service see Starting and Stopping the Windows
Service.

 

For more information, see:

Starting and Stopping the Windows Service
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Troubleshooting
 

SMART Disk Monitor uses a Microsoft technology known as WMI to access SMART status and access
permissions on your networked computers.  The most common error reported by the operating system for
WMI problems are:

         The RPC server is unavailable
         Access Denied

 

We have found it is beneficial to tell customers to first verify the connection or access failure from within the
WMI Control Panel on the computer SMART Disk Monitor is installed.  

 

Connecting to a remote computer within the WMI Control Panel

From the run menu or a command-prompt, type: wmimgmt.msc.  This command will open the WMI Control
Panel within the Microsoft Management Console (MMC).  

Right click on the WMI Control (Local) node located in the left pane.  Select Connect to another computer.  If
running on an OS prior to Windows Vista, you have the option to specify credentials.  If running on Vista, you
no longer have this option.  Specify credentials as necessary.  Lastly, click OK.  

Once the dialog closes, right click on the WMI Control node again and select Properties.  Most users will
receive the RPC server is unavailable or access denied error at this point.

The RPC Server is Unavailable
Typically an RPC error means the remote computer is not allowing WMI packets through its firewall or the
remote computer does not allow remote administration.  The Windows firewall, a third party firewall, or virus
protection software can all block WMI packets.

At this point if you think the remote computer’s Windows firewall is blocking WMI packets or remote
administration is not enabled, please follow this link for more information:  

Configuring the Windows XP Firewall

Otherwise, please continue reading the sections labeled Access Denied and Other Things to Look At below.
 If you are still unable to resolve the error, please read the following MSDN articles:

Connecting to WMI on a Remote Computer

Connecting to WMI Remotely Starting with Vista 

Connecting Through Windows Firewall

Access Denied
Typically an access denied error means the account you are logged in under or the account the Windows
Service is running under does not have the appropriate credentials to run WMI commands.

1.  If monitoring disks from another computer on the network, make sure that the account you are logged in
as and the account the service is running under both have administrative privileges.  For more information
see Security.  If the account you are logged in does not have administrator rights or you are attempting to
access a computer not on the domain, you must map the computer to specify the appropriate credentials.
 For more information see Mapping Computers.

2.  Ensure WMI permissions have been set correctly.  From the remote computer throwing the error, open a
command-prompt and type: wmimgmt.msc.  Right click on the WMI Control (local) node and select
Properties.  Select the Security tab and navigate to root/CIMV2.  Click the Security button.  Grant the account
you and the service are using to access logs Remote Enable and Read Security rights.

3.  When accessing a Windows Vista computer that has joined a workgroup rather than a domain, the
remote Windows Vista computer must disable User Access Control (UAC).  To disable UAC on a Windows
Vista computer, search for Turn UAC off within the Windows help system.
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Other Things to Look At
1. If you have other internal firewalls on your network, you may need to configure them to allow WMI packets.
 Many virus protection solutions such as McAfee and Symantec contain their own firewalls which must be
configured to allow WMI packets. 

2.  If the remote computer is running Windows XP Pro, make sure remote logons are not being coerced to the
GUEST account.  From the computer you are unable to download logs from, open a command-prompt and
type secpol.msc.  Expand the Local Policies node and select Security Options.  Scroll down to the setting
titled Network access: Sharing and security model for local accounts.  If this is set to Guest only, change it
to Classic and restart your computer. 

3.  From the computer you are unable to download logs from, open a command-prompt and type dcomcnfg. 
Expand the Component Services/Computers/My Computer node.  Right click My Computer and then select
Properties.  Select the COM Security tab.  From the Launch and Activation Permissions, select Edit Limits. 
Add the appropriate account and assign all permissions.

4.  Check that DCOM is enabled on both the local and the remote computer.  Check the following registry
value on both computers: Key: HKLM\Software\Microsoft\OLE, value: EnableDCOM, should be set to 'Y' 

5.  Check that WMI is installed on both the local and remote computer.  WMI is present by default in all
flavors of Windows 2000 and later operating systems, but must be installed manually on NT4 systems.  To
check for the presence of WMI, open a command-prompt and type wbemtest.  If the WMI Tester application
starts up, WMI is present, if not, it must be installed.  Consult Microsoft for more information.

6. Make sure no remote access or WMI-related services have been disabled on either the local or remote
computer.  On an XP machine, the following services should be running or enabled: 

         COM+ Event System 
         Remote Access Auto Connection Manager 
         Remote Access Connection Manager 
         Remote Procedure Call (RPC) 
         Remote Procedure Call (RPC) Locator 
         Remote Registry Server 
         Windows Management Instrumentation 
         Windows Management Instrumentation Driver Extensions 
         WMI Performance Adapter 
         Workstation 
 

For more information, see:

Security

Mapping Computers

Configuring the Windows XP Firewall

Connecting to WMI on a Remote Computer

Connecting to WMI Remotely Starting with Vista 

Connecting Through Windows Firewall

http://support.microsoft.com/kb/323076/en-us
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Configuring the Windows XP Firewall
 

Windows XP service pack 2 (SP2) and later include an improved version of the Windows Firewall which is
now enabled by default. 

In its default configuration, the Windows Firewall prevents access to WMI commands across the network.
This will typically be reported by SMART Disk Monitor as "access denied". 

In order to restore access, you'll have to configure the firewall on your XP SP2 computers to allow remote
administration via Windows Management Instrumentation (otherwise known as WMI). 

The simplest way to do this is to open up a command prompt and type the following: 

netsh firewall set service RemoteAdmin

The effect is immediate and there is no need to restart. 

To read more about this, consult the following Microsoft article: 
http://msdn2.microsoft.com/en-us/library/aa389286.aspx

If you are still unable to download or monitor remote logs see Troubleshooting.

 

For more information, see:

http://msdn2.microsoft.com/en-us/library/aa389286.aspx

Security

Troubleshooting
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Security
 

To access administrator shares from the user interface your login must have domain administrator rights.  If
your account does not have domain administrator rights, you can map a computer and specify appropriate
login credentials.  For more information see Mapping Computers.

When scheduling the service to monitor disks the service must be run with domain administrator rights.  The
first time the application is run, you will be prompted to assign domain administrator rights to the service.
 When the password assigned to the account the service is running under changes you must update the
service to use the latest password. For more information see Change Service Login. 

SMART Disk Monitor uses a Microsoft technology known as WMI to monitor SMART status and execute
access permissions reports on your networked computers.  The most common error reported by the
operating system for WMI problems are:

         The RPC server is unavailable
         Access Denied

For more information see Troubleshooting.

 

For more information, see:

Change Service Login

Mapping Computers

Troubleshooting
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Technical Support
 

If you have any problems with SMART Disk Monitor you can contact our tech support by emailing us at:

support@cornerbowl.com

Please make sure you tell us as much information as you can about the problem you are experiencing,
including any error or warning messages that may have been displayed.

Please include the following information with all support requests:

         The version you are running. This information can be obtained from the About box. 
         The ‘dm.log' file. This file is located in the installation directory. The default location is:

o    Window XP/2000: '\documents and settings\all users\application
data\CornerBowl\DiskMonitor\dm.log’

o    Windows Vista: ‘\programdata\CornerBowl\DiskMonitor\dm.log’
 
         The operating system version. 
         If applicable, your license key. 
         Description of your problem. Please provide as much information as possible so we can reproduce

the problem if necessary. 
We’ll try to help you as fast as possible, usually in one or two business days.

If you have any comments or suggestions for the next releases, please feel free to post them to us.

Contact Information
Website: www.cornerbowl.com

Email: support@cornerbowl.com

Phone: 1-(866)-543-9470 (TOLL FREE)
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